Bug 737924 - Switching to a text VC (inside the vm) crashes Xorg
Summary: Switching to a text VC (inside the vm) crashes Xorg
Keywords:
Status: CLOSED DUPLICATE of bug 815360
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-qxl
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 12:06 UTC by Hans de Goede
Modified: 2014-06-18 09:14 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-08 23:58:10 UTC


Attachments (Terms of Use)

Description Hans de Goede 2011-09-13 12:06:39 UTC
Steps to Reproduce:
1. Take a 64 bit F-15 vm, using spice of course
2. Make sure it is fully up2date
3. Login to the fallback gnome desktop
4. switch to a text VT
5. Wait a bit
  
Actual results:
Xorg crashes, and restarts taking you back to the gdm login screen

Expected results:
Being able to work on the text VT and then return to the open
gnome-session.

Additional info:
I've been debugging this and the problem is that src/qxl_surface.c: qxl_surface_kill() gets called on a surface with a NULL host_image, moreover &surface->cache->all_images[id] != surface, so this smells like memory
corruption to me.

Comment 1 Oliver Henshaw 2012-06-22 16:12:10 UTC
Looks like bug #815360.

Comment 2 Cole Robinson 2012-07-08 23:58:10 UTC
Duping to the newer report that's filed against F17

*** This bug has been marked as a duplicate of bug 815360 ***


Note You need to log in before you can comment on or make changes to this bug.