Bug 737940 - split systemd-analyze into a subpackage
split systemd-analyze into a subpackage
Status: CLOSED DUPLICATE of bug 710786
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraServerTracker
  Show dependency treegraph
 
Reported: 2011-09-13 08:55 EDT by Daniel Mach
Modified: 2011-09-13 09:06 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-13 09:06:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Mach 2011-09-13 08:55:52 EDT
systemd-analyze is now part of the systemd.rpm, therefore the package requires python. I don't think it's appropriate for an init to depend on such high-level packages. That's why I recommend to move systemd-analyze to a subpackage.

If you do so, please add also following requires to the subpackage:
Requires: dbus-python
Requires: pycairo
(just my guess, I'm not familiar with either, but these are the best candidates I found)
Comment 1 Michal Schmidt 2011-09-13 09:06:50 EDT

*** This bug has been marked as a duplicate of bug 710786 ***

Note You need to log in before you can comment on or make changes to this bug.