Bug 737965 - Section 3.2. of the migration guide confuses customers about migrating to ext4 from ext3
Summary: Section 3.2. of the migration guide confuses customers about migrating to ex...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Migration_Guide
Version: 6.0
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Laura Bailey
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks: GSS_6_2_PROPOSED 703492 720649
TreeView+ depends on / blocked
 
Reported: 2011-09-13 14:15 UTC by Ric Wheeler
Modified: 2013-02-05 23:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-04 00:52:21 UTC


Attachments (Terms of Use)

Description Ric Wheeler 2011-09-13 14:15:20 UTC
Description of problem:

We need to have a clear statement in this section stating that migration in place from ext3 to ext4 is not supported. The wording there today implies that we do not recommend migration in place and that is not clear enough.
 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Existing text:
It is recommended that those wishing to make use of ext4 start with a freshly formatted partition. However, it is possible to install Red Hat Enterprise Linux 6 with the ext4migrate boot option to convert your legacy ext3 partitions to ext4. It is important to note that by doing this you will not receive all of the benefits ext4 offers, since the data currently residing on the partition will not make use of the extents features and other changes. New data will however make use of extents. Passing this boot option to migrate to ext4 is not recommended and it is strongly recommended that you back up file systems before attempting this migration. 

Expected results:

Suggested text:

Moving to ext4 must be done with a freshly formatted ext4 file system. Migrating in place from ext3 to ext4 is not supported and will not produce many of the benefits ext4 offers, since the data currently residing on the partition will not make use of the extents features and other changes.

Customers who cannot migrate to a cleanly formatted ext4 file system should stay on their existing ext3 file system.


Additional info:

Comment 4 Masaki Furuta 2011-10-04 11:34:26 UTC
Info for NEC:

This bz is now closed as per the following description would be available with 6.2 docs:

---
Verified: Red_Hat_Enterprise_Linux-Migration_Planning_Guide-6-en-US-6.2-53

3.2. ext4
Migration from ext3
Moving to ext4 must be done with a freshly formatted ext4 file system.
Migrating in place from ext3 to ext4 is not supported and will not produce many
of the benefits ext4 offers, since the data currently residing on the partition
will not make use of the extents features and other changes.
Customers who cannot migrate to a cleanly formatted ext4 file system should
stay on their existing ext3 file system.


Note You need to log in before you can comment on or make changes to this bug.