Bug 737968 - "Could not find dependency Service[aeolus-conductor]" Error in Interactive installer
Summary: "Could not find dependency Service[aeolus-conductor]" Error in Interactive in...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-configure
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Mo Morsi
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 14:17 UTC by Aziza Karol
Modified: 2011-11-08 17:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-22 04:07:58 UTC


Attachments (Terms of Use)

Description Aziza Karol 2011-09-13 14:17:55 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.git clone configure from git://git.fedorahosted.org/git/aeolus/configure.git
2.install the rpms
3.sudo /usr/sbin/aeolus-configure -inh
  
Actual results:
Select Aeolus Components to Install
1. All
2. None
3. Image Factory
4. Image Warehouse
5. Conductor
Install Aeolus Component: 2
Launching aeolus configuration recipe...
Could not find dependency Service[aeolus-conductor] for Web_request[admin-conductor-login] at /usr/share/aeolus-configure/modules/aeolus/manifests/conductor.pp:176


Additional info:
[root@pogolinux-1 ~]# rpm -qa | grep  aeolus-configure
aeolus-configure-2.0.2-3.20110913061108gitb90de40.fc15.noarch

Comment 1 Mo Morsi 2011-09-22 04:07:58 UTC
For the time being due to the way profiles work conductor is required for aeolus-configure to work property, thus  it is now always installed by default with the following patch:

http://git.fedorahosted.org/git/?p=aeolus/configure.git;a=commitdiff;h=263f129d7e8668330847b2c58d284640d83f865d


Note You need to log in before you can comment on or make changes to this bug.