Bug 73804 - reload button doesn't work
reload button doesn't work
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: ggv (Show other bugs)
null
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-11 01:59 EDT by Ulrich Drepper
Modified: 2013-04-02 00:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-12 16:27:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2002-09-11 01:59:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020812

Description of problem:
If the reload button is pressed after the PDF file currently displayed changed
on the disk it appears that a new file is loaded (the window is cleared) but the
same old file is displayed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.echo '\documentstyle{article}\begin{document}foo\end{document}' >
 foo.tex
2.pdflatex foo.tex
3.ggv foo.pdf
4.echo '\documentstyle{article}\begin{document}bar\end{document}' > foo.tex
5.pdflatex foo.tex
6.<PRESS RELOAD BUTTON>

	

Actual Results:  Same old text, 'foo'.

Expected Results:  New text, 'bar'.

Additional info:
Comment 1 Jonathan Blandford 2002-09-12 16:27:07 EDT
Forwarded to gnome bugzilla bug #93156
Comment 2 Jonathan Blandford 2002-09-16 15:16:55 EDT
This is fixed upstream.  It's not clear to me what the problem was.  Quite a bit
of code changed between then and now, so I really see a need to back port it. 
Ulrich, if you really want this feature I can build you an unofficial newer version.
Comment 3 Ulrich Drepper 2002-09-16 15:37:51 EDT
It would be good to get working code (I need it for RH work).  This way I can
also verify it's truly fixed.  From what I've read in the Gnome bugzilla entry
this is all but clear.

Note You need to log in before you can comment on or make changes to this bug.