Bug 738070 - Alienware
Summary: Alienware
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 14
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 19:28 UTC by Tino Engel
Modified: 2015-02-01 22:54 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-10 14:13:45 UTC


Attachments (Terms of Use)

Description Tino Engel 2011-09-13 19:28:40 UTC
Description of problem:
abtr-gui cannot report kerneloops to bugzilla.

Version-Release number of selected component (if applicable):
ABRT 1.1.18

How reproducible:
Play with PWC and Deloitte.

Steps to Reproduce:
1. Play with potential female PWC worker in train.
2. Inform Deloitte.
3. Try to report occuring kernel errors.

Actual results:
Error message:
"Kernel oops has not been sent due to Couldn't resolve host name".

Expected results:
Kernel message has been sent.

Additional info:
Money-independent re-founder of 089 as HipHop/Rap band.

Comment 1 Tino Engel 2011-09-14 11:15:12 UTC
A free DynDNS alternative might help to have my dynamic IP resolved. I would like to avoid DynDNS due to its limitation of being free for only 10 years.
Anyone can recommend me a completely free dynamic DNS service to check if the solution is valid?
So far, the MAC address of the eth0 interface used for internet connectivity on my side is 00:26:B9:6F:ED:3E.

Comment 2 Jiri Moskovcak 2011-09-14 12:00:13 UTC
"Couldn't resolve host name" means that it couldn't resolve the name kerneloops.org not yours. This can be caused by multiple reasons like: your dns service is down, your internet connectivity was broken, etc... can you please try to report it again with some reliable internet connection?

Comment 3 Tino Engel 2011-09-14 12:45:47 UTC
Dear Mr. Moskovcak,

Reporting may take some time.

Actually the kernel acts very unstable on trying to produce a trace as follows:
1. dig kerneloops.org
2. report using abtr-gui
3. dig kerneloops.org

What I already could see, is that dig for kerneloops.org changes in column 2 of answer section (is it TTL?).
But it really seams that my system can stablely resolve kerneloops.org.

Strangely having a full duplex rap session with JACK and 5.33ms latency on the M17xR1 integrate Nvidia HD audio runs way more stable (probably due to Planet CCRMA Kernel ;-)).

But at a first glance the M-Net internet connection (Starnberg near Munich) is way more stable than the kernel.

Maybe it is a problem my Gnome shows UTC (12:43) instead of local time although the time zone is configured in Gnome?

Kind regards, Tino Engel

Comment 4 Tino Engel 2011-09-14 13:22:34 UTC
[elgrande@localhost ~]$ date
Mi 14. Sep 15:01:30 CEST 2011
[elgrande@localhost ~]$ echo time has been corrected to right hour and minute
time has been corrected to right hour and minute
[elgrande@localhost ~]$ dig kerneloops.org

; <<>> DiG 9.7.4b1-RedHat-9.7.4-0.3.b1.fc14 <<>> kerneloops.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39738
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;kerneloops.org.			IN	A

;; ANSWER SECTION:
kerneloops.org.		1201	IN	A	140.211.167.41

;; AUTHORITY SECTION:
kerneloops.org.		1081	IN	NS	ns27.domaincontrol.com.
kerneloops.org.		1081	IN	NS	ns28.domaincontrol.com.

;; Query time: 7 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Wed Sep 14 15:02:09 2011
;; MSG SIZE  rcvd: 103

[elgrande@localhost ~]$ abtr-gui
bash: abtr-gui: command not found...
Ein ähnlicher Befehl lautet: 'abrt-gui'
[elgrande@localhost ~]$ abrt-gui

# 1. Selected oldest exisiting open report (2 have been deleted open, 
#    qjackctl and mixxx, one other has been reported locally, mixxx):
#    kernel localhost.localdomain Di 13 Sep 2011 10:19:10
# 2. Pressed button "Bericht".
# 3. Pressed button "Vor".
# 4. Checked "Ich stimme dem Übermitteln der Ablaufverfolgung zu".
# 5. Pressed "Vor".
#    (Note: Description has been entered before)
# 6. Pressed button "Vor".
# 7. Pressed button "Anwenden".
#
# ERROR MESSAGE:
# Kernel oops has not been sent due to Couldn't resolve host name
#
# 8. Pressed button "Schließen".
# 9. Pressed button "Schließen".
#
# (Note: abrt-gui is finished now)
[elgrande@localhost ~]$ dig kerneloops.org

; <<>> DiG 9.7.4b1-RedHat-9.7.4-0.3.b1.fc14 <<>> kerneloops.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13778
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;kerneloops.org.			IN	A

;; ANSWER SECTION:
kerneloops.org.		722	IN	A	140.211.167.41

;; AUTHORITY SECTION:
kerneloops.org.		602	IN	NS	ns27.domaincontrol.com.
kerneloops.org.		602	IN	NS	ns28.domaincontrol.com.

;; Query time: 7 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Wed Sep 14 15:10:08 2011
;; MSG SIZE  rcvd: 103

[elgrande@localhost ~]$ 
[elgrande@localhost ~]$ dig kerneloops.org

; <<>> DiG 9.7.4b1-RedHat-9.7.4-0.3.b1.fc14 <<>> kerneloops.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13778
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;kerneloops.org.			IN	A

;; ANSWER SECTION:
kerneloops.org.		722	IN	A	140.211.167.41

;; AUTHORITY SECTION:
kerneloops.org.		602	IN	NS	ns27.domaincontrol.com.
kerneloops.org.		602	IN	NS	ns28.domaincontrol.com.

;; Query time: 7 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Wed Sep 14 15:10:08 2011
;; MSG SIZE  rcvd: 103

[elgrande@localhost ~]$ 
[elgrande@localhost ~]$ dig kerneloops.org

; <<>> DiG 9.7.4b1-RedHat-9.7.4-0.3.b1.fc14 <<>> kerneloops.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13778
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;kerneloops.org.			IN	A

;; ANSWER SECTION:
kerneloops.org.		722	IN	A	140.211.167.41

;; AUTHORITY SECTION:
kerneloops.org.		602	IN	NS	ns27.domaincontrol.com.
kerneloops.org.		602	IN	NS	ns28.domaincontrol.com.

;; Query time: 7 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Wed Sep 14 15:10:08 2011
;; MSG SIZE  rcvd: 103

[elgrande@localhost ~]$ 
[elgrande@localhost ~]$ dig kerneloops.org

; <<>> DiG 9.7.4b1-RedHat-9.7.4-0.3.b1.fc14 <<>> kerneloops.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13778
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;kerneloops.org.			IN	A

;; ANSWER SECTION:
kerneloops.org.		722	IN	A	140.211.167.41

;; AUTHORITY SECTION:
kerneloops.org.		602	IN	NS	ns27.domaincontrol.com.
kerneloops.org.		602	IN	NS	ns28.domaincontrol.com.

;; Query time: 7 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Wed Sep 14 15:10:08 2011
;; MSG SIZE  rcvd: 103

[elgrande@localhost ~]$

Comment 5 Tino Engel 2011-09-14 13:41:27 UTC
3 additional comments:

1. The kernel crashes I am experiencing currently seem to be related to the (bugzilla.redhat.com) text-box I am writing into right now. I am using current FC14 nouveau driver. After kernel crash X is totally dead except the mouse, which is still working.

2. [elgrande@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.33.13-149.rt31.2.fc14.ccrma.x86_64.rt #1 SMP PREEMPT RT Wed May 11 19:14:10 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux
[elgrande@localhost ~]$ 

3. The manual trace I have submitted at 2011-09-14 09:22:34 EDT should contain o
nly 1 'dig kerneloops.org' before and 1 'dig kerneloops.org' after abtr-gui. Str
angely 3 additional dig dumps now occur within the entry.

Comment 6 Tino Engel 2011-09-14 20:00:19 UTC
Tried to remove duplicate needinfo flag, but couldn't. This 2 updates can be ignored.

Comment 7 Tino Engel 2011-09-15 16:37:05 UTC
Please find below the first log copy pasted:
==================================================================================
Package:    	kernel
Latest Crash:	Di 13 Sep 2011 10:19:10 
Command:    	not_applicable
Reason:     	BUG: unable to handle kernel paging request at ffff880138df8690
Comment:    	Planet CCRMA kernel for FC 14
Bug Reports:

Comment 8 Wayne Walker 2011-09-27 01:58:27 UTC
I have the same problem regarding "Kernel oops has not been sent due to Couldn't resolve host name".  I do not have a DNS resolution problem:


[wwalker@uranium ~] $ dig kerneloops.org

; <<>> DiG 9.7.4b1-RedHat-9.7.4-0.3.b1.fc14 <<>> kerneloops.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40774
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;kerneloops.org.                        IN      A

;; ANSWER SECTION:
kerneloops.org.         1800    IN      A       140.211.167.41

;; Query time: 143 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Mon Sep 26 20:19:20 2011
;; MSG SIZE  rcvd: 48

Comment 9 Vinod Kutty 2011-09-30 00:47:52 UTC
Experiencing the same issue with the uninformative abrt-gui error "Kernel oops has not been sent due to Couldn't resolve host name".

Quick strace suggests that it may be 'submit.kerneloops.org' / 'oops.kernel.org' that is having resolution issues (but kerneloops.org is fine).

This is a recent issue. Resolution failed for me from multiple network locations.


; <<>> DiG 9.7.4b1-RedHat-9.7.4-0.3.b1.fc14 <<>> submit.kerneloops.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 40714
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;submit.kerneloops.org.		IN	A

;; ANSWER SECTION:
submit.kerneloops.org.	1173	IN	CNAME	oops.kernel.org.

;; AUTHORITY SECTION:
kernel.org.		2973	IN	SOA	ns7.kernel.org. hostmaster.ns7.kernel.org. 20110908 3600 600 604800 3600

;; Query time: 27 msec
;; SERVER: 75.75.75.75#53(75.75.75.75)
;; WHEN: Thu Sep 29 19:44:58 2011
;; MSG SIZE  rcvd: 116

Comment 10 Jiri Moskovcak 2011-09-30 06:31:17 UTC
(In reply to comment #9)
> Experiencing the same issue with the uninformative abrt-gui error "Kernel oops
> has not been sent due to Couldn't resolve host name".
> 
> Quick strace suggests that it may be 'submit.kerneloops.org' /
> 'oops.kernel.org' that is having resolution issues (but kerneloops.org is
> fine).
> 
> This is a recent issue. Resolution failed for me from multiple network
> locations.
> 

- indeed kerneloops.org seems to have some troubles, right now (8:25 CET) I can't open the page or ping it. I think it's not problem on abrt side - except the message should say "Connection timed out" rather than "Cannot resolve the hostname", but this message probably comes from underlying libcurl. Please report all the oopses to Red Hat Bugzilla before the problem is fixed (which is the preferred option since F15 anyway).

Comment 11 Jiri Moskovcak 2011-10-10 14:13:45 UTC
I'm going to close this bug as I'm convinced that it's a problem on the kerneloops.org. Please you red hat bugzilla to submit any further oopses.


Note You need to log in before you can comment on or make changes to this bug.