Bug 738089 - [hpcups] 3.11.7/3.11.10: Margins are not being respected
Summary: [hpcups] 3.11.7/3.11.10: Margins are not being respected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 16
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 21:12 UTC by Steven P. Ulrick
Modified: 2012-01-23 22:03 UTC (History)
16 users (show)

Fixed In Version: hplip-3.11.12-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-11 05:58:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 890684 None None None Never

Description Steven P. Ulrick 2011-09-13 21:12:07 UTC
Description of problem:
When I try to print any document, using any program, the top margins are not respected.  For example, a document that is supposed to have the top margin start at about 68 pixels actually prints at about 17 pixels.

Version-Release number of selected component (if applicable):
hplip-3.11.7-2.fc14.x86_64
hplip-libs-3.11.7-2.fc14.x86_64
hplip-common-3.11.7-2.fc14.x86_64
hplip-gui-3.11.7-2.fc14.x86_64

How reproducible:
All attempted print jobs print incorrectly.

Steps to Reproduce:
1. Print a document.
2. 
3.
  
Actual results:
A 68 pixel margin magically becomes a 17 pixel margin

Expected results:
I should be able to print any document that I choose and have the margins be where they were when I created the document.

Additional info: If I downgrade to the following, printing always works exactly as it should:
hplip-3.10.6-3.fc14.x86_64
hplip-libs-3.10.6-3.fc14.x86_64
hplip-common-3.10.6-3.fc14.x86_64
hplip-gui-3.10.6-3.fc14.x86_64

Also, the output of "diff -ur etc-cups-ppd-working /etc/cups/ppd/HP-LaserJet-P2055dn.ppd" reads as follows:

steve@localhost ~$ diff -ur etc-cups-ppd-working /etc/cups/ppd/HP-LaserJet-P2055dn.ppd 
--- etc-cups-ppd-working        2011-09-12 15:07:19.935878232 -0500
+++ /etc/cups/ppd/HP-LaserJet-P2055dn.ppd       2011-09-13 15:47:44.889982117 -0500
@@ -1,6 +1,6 @@
 *PPD-Adobe: "4.3"
 *%%%% PPD file for HP LaserJet p2055dn with CUPS.
-*%%%% Created by the CUPS PPD Compiler CUPS v1.4.8.
+*%%%% Created by the CUPS PPD Compiler CUPS v1.4.4.
 *% (c) 2008 Copyright Hewlett-Packard Development Company, LP
 *FormatVersion: "4.3"
 *FileVersion: "hpcups 3.11.7"

So, margins always print as expected with hplip-3.10.6-3.fc14.x86_64 but always print incorrectly with hplip-3.11.7-2.fc14.x86_64

Comment 1 Tim Waugh 2011-09-14 09:33:16 UTC
It would be interesting to find out how the various versions of hplip built between those two updates behave:

3.11.7-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=255361
3.11.5-4 * http://koji.fedoraproject.org/koji/buildinfo?buildID=250673
3.11.5-3 http://koji.fedoraproject.org/koji/buildinfo?buildID=247166
3.11.5-1 http://koji.fedoraproject.org/koji/buildinfo?buildID=243702
3.11.3a-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=236950
3.11.3-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=234520
3.11.1-3 * http://koji.fedoraproject.org/koji/buildinfo?buildID=231559
3.11.1-2 http://koji.fedoraproject.org/koji/buildinfo?buildID=216983
3.11.1-1 http://koji.fedoraproject.org/koji/buildinfo?buildID=215370
3.10.9-14 * http://koji.fedoraproject.org/koji/buildinfo?buildID=214486
3.10.9-13 http://koji.fedoraproject.org/koji/buildinfo?buildID=213831
3.10.9-11 http://koji.fedoraproject.org/koji/buildinfo?buildID=213796
3.10.9-9 http://koji.fedoraproject.org/koji/buildinfo?buildID=209472
3.10.9-8 http://koji.fedoraproject.org/koji/buildinfo?buildID=207573
3.10.9-6 http://koji.fedoraproject.org/koji/buildinfo?buildID=204755
3.10.9-5 http://koji.fedoraproject.org/koji/buildinfo?buildID=204591
3.10.9-4 http://koji.fedoraproject.org/koji/buildinfo?buildID=202467
3.10.9-3 http://koji.fedoraproject.org/koji/buildinfo?buildID=200939
3.10.9-2 http://koji.fedoraproject.org/koji/buildinfo?buildID=200460
3.10.9-1 http://koji.fedoraproject.org/koji/buildinfo?buildID=198781
3.10.6-7 * http://koji.fedoraproject.org/koji/buildinfo?buildID=198181
3.10.6-5 http://koji.fedoraproject.org/koji/buildinfo?buildID=196054

That's 22 builds, of 7 different versions.  Could you please try each of the builds that I've marked with '*' above?  I'm trying to narrow down which version broke this for you.

To try one of the builds, download the relevant packages for your architecture, and run 'yum downgrade FILES...' replacing FILES... with the full list of the filenames you've downloaded. ("Relevant packages" because you only need the ones you've already got installed... if you don't have libsane-hpaio installed, don't download that package for example.)

Let me know how you get on.

Comment 2 Steven P. Ulrick 2011-09-14 20:39:09 UTC
The following builds produce "404 Not Found" errors when I attempt to download the appropriate files:
3.10.6-7 * http://koji.fedoraproject.org/koji/buildinfo?buildID=198181
3.11.1-3 * http://koji.fedoraproject.org/koji/buildinfo?buildID=231559
3.11.3-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=234520
3.11.3a-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=236950

The other three builds I have already downloaded the RPMS.  I will get started right away.

Comment 3 Steven P. Ulrick 2011-09-14 20:54:41 UTC
As requested:

> 3.11.7-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=255361
Results: Does not print the top margin correctly.

> 3.11.5-4 * http://koji.fedoraproject.org/koji/buildinfo?buildID=250673
Results: Prints top margin correctly.

> 3.11.3a-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=236950
> 3.11.3-1 * http://koji.fedoraproject.org/koji/buildinfo?buildID=234520
> 3.11.1-3 * http://koji.fedoraproject.org/koji/buildinfo?buildID=231559
Attempts to download these three builds resulted in "404 Not Found" errors.

> 3.10.9-14 * http://koji.fedoraproject.org/koji/buildinfo?buildID=214486
Results: Prints top margin correctly.


> 3.10.6-7 * http://koji.fedoraproject.org/koji/buildinfo?buildID=198181
Attempts to download this build resulted in "404 Not Found" error.

So, it looks like 3.11.7-1 and 3.11.7-2 (the current update) are the only ones that cause this problem.

If there are any more builds that you want me to try, let me know.

Comment 4 Robert Locke 2011-09-16 13:12:00 UTC
Just another data point:

Same problem in F15 - same printer HP-LaserJet-p2055dn

Sep 13 15:08:13 Updated: hplip-common-3.11.7-2.fc15.x86_64
Sep 13 15:08:13 Updated: hplip-libs-3.11.7-2.fc15.x86_64
Sep 13 15:08:17 Updated: 1:hpijs-3.11.7-2.fc15.x86_64
Sep 13 15:08:52 Updated: hplip-3.11.7-2.fc15.x86_64
Sep 13 15:08:52 Updated: libsane-hpaio-3.11.7-2.fc15.x86_64
Killed the top margin, text now being cut off

Downgraded the packages
Sep 16 08:04:53 Installed: hplip-common-3.11.3a-1.fc15.x86_64
Sep 16 08:04:54 Installed: hplip-libs-3.11.3a-1.fc15.x86_64
Sep 16 08:04:55 Installed: 1:hpijs-3.11.3a-1.fc15.x86_64
Sep 16 08:04:57 Installed: hplip-3.11.3a-1.fc15.x86_64
Sep 16 08:04:57 Installed: libsane-hpaio-3.11.3a-1.fc15.x86_64
Files print correctly

Redownloaded/updated to previous released update:
Sep 16 08:46:17 Updated: hplip-common-3.11.5-3.fc15.x86_64
Sep 16 08:46:17 Updated: hplip-libs-3.11.5-3.fc15.x86_64
Sep 16 08:46:20 Updated: 1:hpijs-3.11.5-3.fc15.x86_64
Sep 16 08:46:21 Updated: hplip-3.11.5-3.fc15.x86_64
Sep 16 08:46:22 Updated: libsane-hpaio-3.11.5-3.fc15.x86_64
Files print correctly

Comment 5 Nicola Soranzo 2011-09-19 12:41:58 UTC
I had the same problem with a HP LaserJet 4350dtn on Fedora 15, downgrading to hplip-3.11.5-4.fc15 (and related rpms) fixes the problem.

Comment 6 Horst H. von Brand 2011-09-28 00:07:12 UTC
Same problem here with a LaserJet m1522nf MFP via network, using hplip-3.11.7-2.fc15.x86_64.

Comment 7 Domingo Becker 2011-09-28 14:32:23 UTC
I had the same problems with an HP LaserJet 1150 in a F15 i686 and a F14 i686.

For F15: 
hplip-3.11.7-2.fc15.i686

For F14: 
hplip-3.11.7-2.fc14.i686

If you try adding blank lines at the beginning of the document, they are wiped out too.

If I print from the F14 to a printer connected to an F13 box using hplip-3.11.5-1.fc13.i686 through the network, it prints well.

Comment 8 Rex Dieter 2011-09-28 18:07:35 UTC
ditto with hp laserjet 2035n + hplip-3.11.7-2.fc14.i686

Comment 9 Andrew McNabb 2011-09-28 20:26:36 UTC
I'm experiencing this problem (or something similar) with an HP LaserJet P4015.

Comment 10 Christian Fillion 2011-10-01 01:55:34 UTC
Same problem with a HP LaserJet 3030.

Comment 11 Robert K. Moniot 2011-10-03 14:39:30 UTC
We see same problem with HP LaserJet p4014dn.
Changing driver from default hpcups to hpijs cures it.

Comment 12 Domingo Becker 2011-10-03 15:49:42 UTC
(In reply to comment #11)
> We see same problem with HP LaserJet p4014dn.
> Changing driver from default hpcups to hpijs cures it.

It works for me too.
I changed to hpijs and my hp LaserJet 1150 respects the top margin again.
Thank you.

Comment 13 Horst H. von Brand 2011-10-04 20:05:10 UTC
Still the same with hplip-3.11.10-1.fc15.x86_64 from koji.

Comment 14 Andrew McNabb 2011-10-18 20:18:45 UTC
After 3 weeks without any new developments, I decided to change my driver from hpcups to hpijs.  The margin problem seems to be fixed.

Comment 15 Horst H. von Brand 2011-10-28 17:22:07 UTC
I went for the foomatic driver, problem solved.

Comment 16 Steven P. Ulrick 2011-11-09 16:31:09 UTC
Just did a fresh install of Fedora 16.  The bug that necessitated me filing this bug report has followed me (and I assume all the others that have commented on this bug) to Fedora 16.  I will apply a workaround to get my printer working correctly, but hplip is still broken.

Comment 17 Steven P. Ulrick 2011-11-09 16:52:40 UTC
Please advise about any different versions of hplip I can try until this bug gets fixed.  The build that worked for me on Fedora 14 has had the Fedora 16 RPM's deleted.

Comment 18 Steven P. Ulrick 2011-11-10 18:34:28 UTC
Last comment was a little premature.  If I downgrade to 3.11.5-5, the top margin prints correctly again.

For anyone else that has this problem, but wants to use the hplip driver, the 3.11.5-5 build of hplip can be found here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=252270

So, at least I can use my printer until an update for hplip is released.

Comment 19 Danny Ciarniello 2011-11-12 05:00:19 UTC
I have the same (or at least a very similar problem) with 3.11.10 and an Office Jet Pro 8000.  3.11.7-? worked fine for me with Fedora 14 and 3.11.7-5 for Fedora 16 also seems to be working.

Comment 22 Jiri Popelka 2011-11-14 12:32:58 UTC
So far we know that downgrade 3.11.7 -> 3.11.5 or change hpcups->hpijs fixes (except for comment #19) the problem. That means that the problem was introduced in hpcups driver between 3.11.5 and 3.11.7. Diff has shown that there was only one change in hpcups driver. So I've done a F16 scratch-build [1] with this change reverted and it would be great if some of you could test it to confirm/disprove that this change has been causing the problem.

[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=3512348

Comment 23 Nicola Soranzo 2011-11-14 14:40:25 UTC
(In reply to comment #22)
> So far we know that downgrade 3.11.7 -> 3.11.5 or change hpcups->hpijs fixes
> (except for comment #19) the problem. That means that the problem was
> introduced in hpcups driver between 3.11.5 and 3.11.7. Diff has shown that
> there was only one change in hpcups driver. So I've done a F16 scratch-build
> [1] with this change reverted and it would be great if some of you could test
> it to confirm/disprove that this change has been causing the problem.
> 
> [1] http://koji.fedoraproject.org/koji/taskinfo?taskID=3512348

This revert fixes the problem for me on a HP LaserJet 4350dtn with hpcups drivers!

Comment 24 Christian Fillion 2011-11-14 15:28:48 UTC
(In reply to comment #22)
> So far we know that downgrade 3.11.7 -> 3.11.5 or change hpcups->hpijs fixes
> (except for comment #19) the problem. That means that the problem was
> introduced in hpcups driver between 3.11.5 and 3.11.7. Diff has shown that
> there was only one change in hpcups driver. So I've done a F16 scratch-build
> [1] with this change reverted and it would be great if some of you could test
> it to confirm/disprove that this change has been causing the problem.
> 
> [1] http://koji.fedoraproject.org/koji/taskinfo?taskID=3512348

That fixes the problem for me too.

Comment 25 Jiri Popelka 2011-11-14 16:33:13 UTC
Thanks!
Could you actually also try the hplip-3.11.10-7.fc16 from stable repository to make sure the problem is still there. The "yum downgrade 'hplip*' hpijs" should do the trick when you are already using my hplip-3.11.10-8.fc16 build.

Comment 26 Nicola Soranzo 2011-11-14 17:26:24 UTC
(In reply to comment #25)
> Thanks!
> Could you actually also try the hplip-3.11.10-7.fc16 from stable repository to
> make sure the problem is still there. The "yum downgrade 'hplip*' hpijs" should
> do the trick when you are already using my hplip-3.11.10-8.fc16 build.

Yes, after downgrading to hplip-3.11.10-7.fc16 the problem with hpcups comes back.

Comment 27 Steven P. Ulrick 2011-11-15 00:56:14 UTC
(In reply to comment #22)
> So far we know that downgrade 3.11.7 -> 3.11.5 or change hpcups->hpijs fixes
> (except for comment #19) the problem. That means that the problem was
> introduced in hpcups driver between 3.11.5 and 3.11.7. Diff has shown that
> there was only one change in hpcups driver. So I've done a F16 scratch-build
> [1] with this change reverted and it would be great if some of you could test
> it to confirm/disprove that this change has been causing the problem.
> 
> [1] http://koji.fedoraproject.org/koji/taskinfo?taskID=3512348

This build fixes the problem for me :)

Comment 28 Danny Ciarniello 2011-11-15 05:40:05 UTC
And I'll add my thumbs up as well.

Comment 29 Jiri Popelka 2011-11-15 13:40:34 UTC
Reported upstream as https://bugs.launchpad.net/hplip/+bug/890684

Comment 30 Jiri Popelka 2011-11-16 15:21:31 UTC
All: If you are interested in helping HP narrow down the issue you can provide some requested information in the upstream bug https://bugs.launchpad.net/ubuntu/+bug/890684

Comment 32 Nicola Soranzo 2011-11-17 14:54:36 UTC
(In reply to comment #31)
> hplip-3.11.10 builds with the work-around applied:
> [F14] http://koji.fedoraproject.org/koji/buildinfo?buildID=274394
> [F15] http://koji.fedoraproject.org/koji/buildinfo?buildID=274391
> [F16] http://koji.fedoraproject.org/koji/buildinfo?buildID=270875
> [F17] http://koji.fedoraproject.org/koji/buildinfo?buildID=274387

I can confirm that also this build for F16 works correctly for me.

Comment 33 Robert Marcano 2011-12-05 19:40:43 UTC
(In reply to comment #31)
> hplip-3.11.10 builds with the work-around applied:
> [F14] http://koji.fedoraproject.org/koji/buildinfo?buildID=274394
> [F15] http://koji.fedoraproject.org/koji/buildinfo?buildID=274391
> [F16] http://koji.fedoraproject.org/koji/buildinfo?buildID=270875
> [F17] http://koji.fedoraproject.org/koji/buildinfo?buildID=274387

Solves the problem here too on HP LaserJet 3055

Comment 34 Fedora Update System 2011-12-07 16:18:25 UTC
hplip-3.11.10-11.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/hplip-3.11.10-11.fc16

Comment 35 Fedora Update System 2011-12-10 19:58:07 UTC
Package hplip-3.11.10-11.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.11.10-11.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16911/hplip-3.11.10-11.fc16
then log in and leave karma (feedback).

Comment 36 Fedora Update System 2011-12-19 17:30:03 UTC
hplip-3.11.12-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/hplip-3.11.12-1.fc15

Comment 37 Fedora Update System 2011-12-22 22:32:22 UTC
Package hplip-3.11.12-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.11.12-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16911/hplip-3.11.12-1.fc16
then log in and leave karma (feedback).

Comment 38 Jiri Popelka 2012-01-02 11:27:19 UTC
All: There's hplip-3.11.12 in updates-testing which includes upstream fix for this problem.

Comment 39 Fedora Update System 2012-01-11 05:58:28 UTC
hplip-3.11.12-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 40 Fedora Update System 2012-01-23 22:03:13 UTC
hplip-3.11.12-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.