Bug 73809 - snmpd is reporting wrong used/free memory sizes
snmpd is reporting wrong used/free memory sizes
Status: CLOSED DUPLICATE of bug 67610
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-11 04:49 EDT by Silver Kuusk
Modified: 2015-03-04 20:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-11 04:50:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Silver Kuusk 2002-09-11 04:49:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
When I use snmpwalk to get the used/free memory, I do not get the proper output.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Change snmpd.conf file so, that you can access enterprises subtree.
2. Execute 'snmpwalk localhost public enterprises.ucdavis.memory'

	

Actual Results:  You get something like that:

enterprises.ucdavis.memory.memIndex.0 = 0
enterprises.ucdavis.memory.memErrorName.0 = swap
enterprises.ucdavis.memory.memTotalSwap.0 = -1
enterprises.ucdavis.memory.memAvailSwap.0 = -1
enterprises.ucdavis.memory.memTotalReal.0 = -1
enterprises.ucdavis.memory.memAvailReal.0 = -1
enterprises.ucdavis.memory.memTotalFree.0 = -2
enterprises.ucdavis.memory.memMinimumSwap.0 = 16000
enterprises.ucdavis.memory.memShared.0 = -1
enterprises.ucdavis.memory.memBuffer.0 = -1
enterprises.ucdavis.memory.memCached.0 = -1
enterprises.ucdavis.memory.memSwapError.0 = 1
enterprises.ucdavis.memory.memSwapErrorMsg.0 = Running out of swap space (-1)


Expected Results:  But right output is:

enterprises.ucdavis.memory.memIndex.0 = 0
enterprises.ucdavis.memory.memErrorName.0 = swap
enterprises.ucdavis.memory.memTotalSwap.0 = 132536
enterprises.ucdavis.memory.memAvailSwap.0 = 128632
enterprises.ucdavis.memory.memTotalReal.0 = 125748
enterprises.ucdavis.memory.memAvailReal.0 = 6968
enterprises.ucdavis.memory.memTotalFree.0 = 135600
enterprises.ucdavis.memory.memMinimumSwap.0 = 16000
enterprises.ucdavis.memory.memShared.0 = 0
enterprises.ucdavis.memory.memBuffer.0 = 2380
enterprises.ucdavis.memory.memCached.0 = 58920
enterprises.ucdavis.memory.memSwapError.0 = 0
enterprises.ucdavis.memory.memSwapErrorMsg.0 = 


Additional info:
Comment 1 Phil Knirsch 2002-10-04 08:15:01 EDT

*** This bug has been marked as a duplicate of 67610 ***

Note You need to log in before you can comment on or make changes to this bug.