Bug 738091 - libgmpxx has unused direct shlib dependency on libm
Summary: libgmpxx has unused direct shlib dependency on libm
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gmp
Version: rawhide
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Peter Schiffer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 21:13 UTC by Jerry James
Modified: 2011-11-09 18:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-09 18:23:36 UTC


Attachments (Terms of Use)
Patch to fix unused direct dependency on libm (1.17 KB, patch)
2011-09-13 21:13 UTC, Jerry James
no flags Details | Diff

Description Jerry James 2011-09-13 21:13:36 UTC
Created attachment 523011 [details]
Patch to fix unused direct dependency on libm

Description of problem:
$ rpmlint gmp
gmp.x86_64: W: spelling-error %description -l en_US fullwords -> full words, full-words, forewords
gmp.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libgmpxx.so.4.1.2 /lib64/libm.so.6

I suspect that this unused direct shared library dependency is why some of my packages get the same warning, because they link against libgmpxx.  The cause is good old libtool, which thinks that EVERYTHING needs to be linked with -lm.  I am attaching one way of solving the problem.  Pardon my conversion of the perl invocation to sed; I understand sed quite well, and perl hardly at all.

Version-Release number of selected component (if applicable):
gmp-4.3.2-4.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. rpmlint gmp
2.
3.
  
Actual results:
Rpmlint reports an unused direct shared library dependency on libm.

Expected results:
No unused direct shared library dependencies.

Additional info:

Comment 1 Peter Schiffer 2011-11-09 18:23:36 UTC
fixed in:
gmp-5.0.2-3.fc17
https://koji.fedoraproject.org/koji/buildinfo?buildID=268643


Note You need to log in before you can comment on or make changes to this bug.