Bug 738103 - Socket read("..") regression
Summary: Socket read("..") regression
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 23:07 UTC by Jóhann B. Guðmundsson
Modified: 2011-09-21 18:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-21 18:00:55 UTC


Attachments (Terms of Use)

Description Jóhann B. Guðmundsson 2011-09-13 23:07:53 UTC
Description of problem:

Not sure what's going on here but we are hitting regression anyway created two finger units for the related xinetd service who work fine on F15 borked on F16 

Long story put short 

[root@localhost ~]# systemctl start finger.socket
[root@localhost ~]# systemctl status finger.socket
finger.socket - Finger Activation Socket
	  Loaded: loaded (/lib/systemd/system/finger.socket; disabled)
	  Active: active (listening) since Tue, 13 Sep 2011 22:26:08 +0000; 32min ago
	Accepted: 3; Connected: 0
	  CGroup: name=systemd:/system/finger.socket
[root@localhost ~]# netstat -pant | grep LISTEN | grep 79
tcp        0      0 :::79                       :::*                        LISTEN      1/init              
[root@localhost ~]# finger root@localhost
[root@localhost ~]# 

Skipping a bit further ahead...

Strace when connecting to the socket activated in systemd on F16

lseek(4, 0, SEEK_CUR)                   = -1 ESPIPE (Illegal seek)
read(4, "", 4096)                       = 0 <--read "" empty where's my pony? 

Strace when finger is enabled and activated in xinetd on F16

lseek(4, 0, SEEK_CUR)                   = -1 ESPIPE (Illegal seek)
read(4, "Login: root           \t\t\tName: r"..., 4096) = 170 <--Here's my pony

As you can see read is missing "Login: root           \t\t\tName: r"

See bug 737178 for further details which contain the unit files in question.


Version-Release number of selected component (if applicable):

systemd-35-1.fc16.x86_64
systemd-sysv-35-1.fc16.x86_64
systemd-units-35-1.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. systemctl start finger.socket
2. finger root@localhost
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jóhann B. Guðmundsson 2011-09-14 11:52:09 UTC
This can be closed as this is already know and I should have known it myself

http://thread.gmane.org/gmane.comp.sysutils.systemd.devel/3267/focus=3269


Note You need to log in before you can comment on or make changes to this bug.