Bug 738121 - Cannot load plugin 'Color'
Summary: Cannot load plugin 'Color'
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 02:59 UTC by Akira TAGOH
Modified: 2011-09-15 15:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-15 15:03:34 UTC


Attachments (Terms of Use)

Description Akira TAGOH 2011-09-14 02:59:05 UTC
Description of problem:
from .xsession-errors:
** (gnome-settings-daemon:3595): WARNING **: /usr/lib64/gnome-settings-daemon-3.0/libcolor.so: undefined symbol: cd_client_get_has_server

** (gnome-settings-daemon:3595): WARNING **: Cannot load plugin 'Color' since file '/usr/lib64/gnome-settings-daemon-3.0/libcolor.so' cannot be read.

** (gnome-settings-daemon:3595): WARNING **: Error activating plugin 'Color'


Version-Release number of selected component (if applicable):
gnome-settings-daemon-3.1.91-1.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1.log into the GNOME desktop
2.see .xsession-errors
3.
  
Actual results:
the above warnings are output

Expected results:
no warnings

Additional info:
there are more undefined symbols issue in libcolor.so:
$ ldd -r /usr/lib64/gnome-settings-daemon-3.0/libcolor.so 
...
undefined symbol: notify_notification_show	(/usr/lib64/gnome-settings-daemon-3.0/libcolor.so)
undefined symbol: notify_notification_set_timeout	(/usr/lib64/gnome-settings-daemon-3.0/libcolor.so)
undefined symbol: gnome_settings_plugin_get_type	(/usr/lib64/gnome-settings-daemon-3.0/libcolor.so)
undefined symbol: notify_notification_new	(/usr/lib64/gnome-settings-daemon-3.0/libcolor.so)
undefined symbol: notify_notification_set_urgency	(/usr/lib64/gnome-settings-daemon-3.0/libcolor.so)
undefined symbol: _gnome_settings_profile_log	(/usr/lib64/gnome-settings-daemon-3.0/libcolor.so)
undefined symbol: notify_notification_set_app_name	(/usr/lib64/gnome-settings-daemon-3.0/libcolor.so)
undefined symbol: notify_notification_add_action	(/usr/lib64/gnome-settings-daemon-3.0/libcolor.so)
undefined symbol: cd_client_get_has_server	(/usr/lib64/gnome-settings-daemon-3.0/libcolor.so)

Comment 1 Matthias Clasen 2011-09-15 15:03:34 UTC
Fixed upstream


Note You need to log in before you can comment on or make changes to this bug.