Bug 738131 - Topic 4413 should be invalid but breaks the book
Summary: Topic 4413 should be invalid but breaks the book
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: PressGang CCMS
Classification: Community
Component: Web-UI
Version: 1.x
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Misty Stanley-Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 04:35 UTC by Misty Stanley-Jones
Modified: 2014-06-18 07:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-15 03:05:26 UTC


Attachments (Terms of Use)

Description Misty Stanley-Jones 2011-09-14 04:35:56 UTC
Topic 4413 breaks building of the EAP 6 Alpha because of a mismatched tag error. I think the problem is that there is a DTD header inside the CDATA.

Comment 1 Matthew Casperson 2011-09-14 22:33:17 UTC
Fixed in 20110915-0830

The issue is that the error page includes the original XML in a cdata section. This was causing problems if the original XML already had a cdata section, because they can not be nested. 

The end cdata tag in the original XML ]]> is now replaced with ]]> when included in the error page.

Comment 2 Misty Stanley-Jones 2011-09-15 03:05:26 UTC
Fixed.


Note You need to log in before you can comment on or make changes to this bug.