Bug 738139 - SIGABRT due to XError in tooltip-handling in applet within system-config-printer-1.1.16-17.el6_1.2
Summary: SIGABRT due to XError in tooltip-handling in applet within system-config-prin...
Keywords:
Status: CLOSED DUPLICATE of bug 739745
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-printer
Version: 6.3
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 05:34 UTC by prashant ingale
Modified: 2013-03-01 05:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-17 11:06:54 UTC


Attachments (Terms of Use)

Description prashant ingale 2011-09-14 05:34:29 UTC
Description of problem:
Process /usr/bin/python was killed by signal 6

Version-Release number of selected component (if applicable):
system-config-printer-1.1.16-17.el6_1.2

How reproducible:
randomly

Steps to Reproduce:
1.
2.
3.
  
Actual results:
system-config-printer is crashed

Expected results:
system-config-printer should not crashed

Additional info:

Comment 2 Dave Malcolm 2011-09-15 12:45:56 UTC
Thanks for filing this bug report.

Looking at the backtrace, this looks like a C-level assertion failure inside GDK due to an error talking to the X server whilst handling tooltips (frames #0-#6).

Starting at the textual bottom of the backtrace and working back up the file:
Frames #56 - #51: /usr/bin/python starting up, running /usr/share/system-config-printer/applet.py
Frames #50 - #42: appears to be a Python call to gtk.main(), running the GTK main loop
Frames #41 - #38: a timeout has happened, calling back into Python code
Frames #37 - #33: appears to be a call to an instance method of a Monitor instance
Frames #32 - #30: appears to be a call to an instance method of a JobViewer instance
Frames #29 - #20: running various Python code, which appears to be making a nested call into gtk.main()
Frames #19 - #11: appears to be within the nested invocation of gtk.main()
Frames #10 - #8: code related to GTK's implementation of tooltips, leading to:
Frame #7: a call to XTranslateCoordinates
Frames #6 - #0: an XError appears to have resulted from the call to XTranslateCoordinates(), and the process aborts.

[Reassigning component from "python" to "system-config-printer" and editing the "Subject" line to be more descriptive]

Comment 3 Tim Waugh 2011-10-17 11:06:54 UTC

*** This bug has been marked as a duplicate of bug 739745 ***


Note You need to log in before you can comment on or make changes to this bug.