Bug 738157 - qemu-kvm doesn't give the fitable error tip when create image
Summary: qemu-kvm doesn't give the fitable error tip when create image
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 6.2
Assignee: Anthony Liguori
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 07:48 UTC by langfang
Modified: 2014-07-25 03:07 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-26 04:30:05 UTC


Attachments (Terms of Use)

Description langfang 2011-09-14 07:48:19 UTC
Description of problem:
senario 1)when run the command:'qemu-img create qed win7.qed 10G',
the error tip is not fitable,in fact,this error is  missing parameter '-f'
senario 2)when run the command :'qemu-img create qcow2 win7.qed 10G',the error tip is not fitable.
senario 3)when run the command :'qemu-img create raw win7.qed 10G',the error tip is not fitable.
Version-Release number of selected component (if applicable):
#uname -r
2.6.32-191.el6.x86_64
#rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.189.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.qemu-img create qed win7.qed 10G or ..qcow2.. or ..raw.. 
  
Actual results:
qemu-img: Invalid image size specified! You may use k, M, G or T suffixes for 
qemu-img: kilobytes, megabytes, gigabytes and terabytes.

Expected results:
qemu-kvm should give user a fitable error tip.

Additional info:

Comment 2 Dor Laor 2011-09-15 07:28:35 UTC
You should specify '-f' before the image format, it does work for me this way, cay you please retest?

Comment 3 langfang 2011-09-15 07:46:44 UTC
dor Laor,thanks for your advice.but i think you misunderstand my mean,i mean when run the command missing '-f',for example:'qemu-img create qed win7.qed 10G'
the error is :
'qemu-img: Invalid image size specified! You may use k, M, G or T suffixes for 
 qemu-img: kilobytes, megabytes, gigabytes and terabytes.'
i think this tip is not fitable for this kind of error .thanks~~~~~~~

Comment 4 Dor Laor 2011-09-25 12:10:19 UTC
But the -f should be compulsory meaning this is not a bug


Note You need to log in before you can comment on or make changes to this bug.