Bug 738193 - rhn_check fails when RHN channels are changed
Summary: rhn_check fails when RHN channels are changed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin
Version: 5.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michael Mráka
QA Contact: Martin Minar
URL:
Whiteboard:
Depends On:
Blocks: 738962
TreeView+ depends on / blocked
 
Reported: 2011-09-14 10:13 UTC by Šimon Lukašík
Modified: 2016-07-04 00:56 UTC (History)
6 users (show)

Fixed In Version: yum-rhn-plugin-0.5.4-25.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 738962 (view as bug list)
Environment:
Last Closed: 2012-02-21 06:29:14 UTC


Attachments (Terms of Use)
snippet from /var/log/up2date (10.64 KB, text/plain)
2011-09-14 10:16 UTC, Šimon Lukašík
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0162 normal SHIPPED_LIVE yum-rhn-plugin bug fix update 2012-02-20 15:07:13 UTC

Description Šimon Lukašík 2011-09-14 10:13:40 UTC
Description of problem:
rhn_check events from 'packages.' namespace fail, when the caching file
(rhnplugin.repos) contains outdated information.

Version-Release number of selected component (if applicable):
yum-rhn-plugin-0.5.4-22.el5_7.2

How reproducible:
always

Steps to Reproduce:
1. Register system with RHN Hosted to the base channel
   (e.g. rhel-i386-server-5)
2. # yum repolist
3. Register system with RHN Satellite without any channel
4. Schedule 'Update Package List' on RHN Satellite webui
5. # rhn_check -vv

Actual results:
Fatal error in Python code occured

yum.Errors.RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-i386-server-5. Please verify its path and try again

Expected results:
rhn_check tool should not crash, even in case the rhnplugin.repos
contains outdated information.

Additional info:

Comment 1 Šimon Lukašík 2011-09-14 10:16:29 UTC
Created attachment 523112 [details]
snippet from /var/log/up2date

Comment 2 Šimon Lukašík 2011-09-14 10:48:49 UTC
Regression against earlier rhel5 releases (rhel5.5 and older).

Comment 4 henry 2011-09-15 15:26:36 UTC
Having this issue as well.

I've tried to manually clean up /var/cache/yum to force an update of the rhnplugin.repos but I am unable to get a usable rhnplugin.repo file.

Has anyone managed a work-around?

Thanks,
Henry

Comment 5 henry 2011-09-15 15:28:02 UTC
Edit:

This is on RHEL6.1

Comment 6 henry 2011-09-15 16:02:51 UTC
(In reply to comment #5)
> Edit:
> 
> This is on RHEL6.1

More debugging -- turning off SSL in /etc/sysconfig/rhn/update lets rhn_check succeed and everything else work as expected.

My issues appear to be duplicates of #692118 and corresponding Fedora bugs:
738566 - python-urlgrabber
738367 - yum
738568 - anaconda

Comment 7 Šimon Lukašík 2011-09-28 18:22:18 UTC
Added RHTS keyword.

QA would like to have an automated test for this issue. Well, currently,
the issue might be exposed by our automation, when series of different
tests make a use of different channel sets. However, having separate test
for this issue, would be a preferred. That way, would would minimize the
risk that test cases gets lost by yum-clean-like workarounds.

Added qa_ack+ as well.

Comment 8 Michael Mráka 2011-10-03 08:56:49 UTC
The issue has been already fixed by z-stream errata package
yum-rhn-plugin-0.5.4-22.el5_7.2.noarch.

Comment 9 Michael Mráka 2011-10-03 09:31:12 UTC
The issue has been addressed as a part of bug 734965 and bug 735282.

Comment 13 errata-xmlrpc 2012-02-21 06:29:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0162.html


Note You need to log in before you can comment on or make changes to this bug.