Bug 738194 - ipvsadm cannot create IPv6 virtual service
Summary: ipvsadm cannot create IPv6 virtual service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Neil Horman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 10:13 UTC by Bjorn Hansson
Modified: 2011-09-24 04:37 UTC (History)
8 users (show)

Fixed In Version: kernel-3.1.0-0.rc6.git0.3.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-24 04:37:37 UTC


Attachments (Terms of Use)

Description Bjorn Hansson 2011-09-14 10:13:54 UTC
Description of problem:


Version-Release number of selected component (if applicable):
ipvsadm-1.26-2.fc16.x86_64


Steps to Reproduce:
1. Install package ipvsadm
2. Run "ipvsadm -A -t [fc00::1]:80"
 

Actual results:
Error message "Operation not supported with specified address family"


Expected results:
Virtual service should be added for IPv6, as for IPv4, ie. "ipvsadm -A -t 192.168.2.20:80" works as expected.

Additional info:

Comment 1 Matthias Saou 2011-09-14 10:59:34 UTC
This is not a limitation in the userland tool, as ipvsadm 1.26 should support IPv6 just fine. I had a quick look at my Fedora kernel's configuration, and this seems to be the "problem":

CONFIG_IP_VS=m
# CONFIG_IP_VS_IPV6 is not set

The IPv6 support for LVS isn't enabled in the kernel. Reassigning to the kernel component, as that's where the change needs to happen for it to work.

Comment 2 Neil Horman 2011-09-14 19:42:02 UTC
Ok, I've enabled this in rawhide and f16.  Should be available in the next build. Please cc or assign me to ipvs on ipv6 bugs that come in.  Thanks!

Comment 3 Fedora Update System 2011-09-16 13:58:31 UTC
kernel-3.1.0-0.rc6.git0.3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.1.0-0.rc6.git0.3.fc16

Comment 4 Fedora Update System 2011-09-17 19:33:33 UTC
Package kernel-3.1.0-0.rc6.git0.3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.1.0-0.rc6.git0.3.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-3.1.0-0.rc6.git0.3.fc16
then log in and leave karma (feedback).

Comment 5 Bjorn Hansson 2011-09-22 19:48:32 UTC
This works as expected now! Thanks for everything!

Comment 6 Neil Horman 2011-09-22 19:53:40 UTC
cool, no problem :)

Comment 7 Fedora Update System 2011-09-24 04:37:04 UTC
kernel-3.1.0-0.rc6.git0.3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.