Bug 738211 - [regression]usermode can not load the installation files from HTTP
Summary: [regression]usermode can not load the installation files from HTTP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst
Version: 6.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 748554
TreeView+ depends on / blocked
 
Reported: 2011-09-14 10:39 UTC by Daisy Wu
Modified: 2011-12-06 16:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2011-12-06 16:17:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1643 normal SHIPPED_LIVE python-virtinst bug fix and enhancement update 2011-12-06 00:50:36 UTC

Description Daisy Wu 2011-09-14 10:39:31 UTC
Description of problem:
usermode can not load the installation files from HTTP

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-6.el6
libvirt-0.9.4-11.el6
python-virtinst-0.600.0-3.el6
qemu-kvm-0.12.1.2-2.184.el6.x86_64

# uname -a
Linux localhost.localdomain 2.6.32-191.el6.x86_64 #1 SMP Wed Aug 17 20:22:22 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
always

Steps to Reproduce:
1. Login as normal user.
2. Click on the local connection. The connection should be localhost(QEMU Usermode)
#virt-manager -c qemu:///session
3. Click NEW button at the top of Virtual Machine Manager dialog.
4. Fill out virtual machine name and select "Network Install(HTTP,FTP or NFS)",and Click "Forward" button.
5. Enter URL in "URL" field, such as http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL5.7-Server-20110409.3/tree-x86_64/
6. Check "Automatically detect operating system based on install media"
7. Click "Forward" button.
8. Select Memory and CPUs, and click Forward.
9. Check "Enable storage for this virtual machine",Select the size for "create a disk image on the comupter's hard drive,uncheck "Allocate entire disk now".
10. Click "Forward" button.
11. Open "Advanced options",check "Set a fixed mac address",select the correct architecture according to the http url. untick "Customize configuration before install". 
12. Click "Finish" button.
  
Actual results:
error pop up:
Unable to complete install: 'Could not start storage pool: cannot open path '/var/lib/libvirt/boot': Permission denied'

Expected results:
Normal user can install guest from HTTP.

Additional info:
It worked well with RHEL6.1 pkgs such as:
python-virtinst-0.500.5-3.el6.noarch
virt-manager-0.8.6-4.el6.noarch
libvirt-0.8.7-18.el6.x86_64

Comment 3 Cole Robinson 2011-09-22 15:00:14 UTC
Issue is actually in virtinst, fixed upstream now:

http://git.fedorahosted.org/git?p=python-virtinst.git;a=commit;h=7e4e0f5da18f55fa382260d9939fd415dd0272c9

Comment 4 Cole Robinson 2011-10-13 21:45:36 UTC
Fixed in python-virtinst-0.600.0-4.el6

Comment 6 Huming Jiang 2011-10-19 10:06:32 UTC
Reproduced with the following package:
python-virtinst-0.600.0-3.el6.noarch

Verified with
kernel-2.6.32-197.el6.x86_64
qemu-kvm-0.12.1.2-2.192.el6.x86_64
libvirt-0.9.4-17.el6.x86_64
python-virtinst-0.600.0-5.el6.noarch
virt-manager-0.9.0-7.el6.x86_64

step:
1. Login as normal user.
2. Click on the local connection. The connection should be localhost(QEMU
Usermode)
#virt-manager -c qemu:///session
3. Click NEW button at the top of Virtual Machine Manager dialog.
4. Fill out virtual machine name and select "Network Install(HTTP,FTP or
NFS)",and Click "Forward" button.
5. Enter URL in "URL" field, such as
http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL6.2-20111013.1/6.2/Server/x86_64/os/
6. Check "Automatically detect operating system based on install media"
7. Click "Forward" button.
8. Select Memory and CPUs, and click Forward.
9. Check "Enable storage for this virtual machine",Select the size for "create
a disk image on the comupter's hard drive,uncheck "Allocate entire disk now".
10. Click "Forward" button.
11. Open "Advanced options",check "Set a fixed mac address",select the correct
architecture according to the http url. untick "Customize configuration before
install".
12. Click "Finish" button.

The guest will be successfully installed with no error.
13. #virsh dumpxml guest
...
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw' cache='none'/>
      <source file='/home/test/VirtualMachines/guest.img'/>
      <target dev='vda' bus='virtio'/>
      <alias name='virtio-disk0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </disk>
...

So move the status of the bug to "verified".

Comment 7 Cole Robinson 2011-11-07 16:54:32 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary

Comment 8 errata-xmlrpc 2011-12-06 16:17:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1643.html


Note You need to log in before you can comment on or make changes to this bug.