Bug 738216 - [Regression][virt-install] install failed when using --nonetworks
Summary: [Regression][virt-install] install failed when using --nonetworks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 748554
TreeView+ depends on / blocked
 
Reported: 2011-09-14 10:49 UTC by zhe peng
Modified: 2011-12-06 16:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2011-12-06 16:17:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1643 normal SHIPPED_LIVE python-virtinst bug fix and enhancement update 2011-12-06 00:50:36 UTC

Description zhe peng 2011-09-14 10:49:28 UTC
Description of problem:
an error occur when using --nonetworks to install guest
 

Version-Release number of selected component (if applicable):
libvirt-0.9.4-11.el6
python-virtinst-0.600.0-3.el6
qemu-kvm-0.12.1.2-2.184.el6


How reproducible:
always

Steps to Reproduce:
1.run command line:
[root@localhost ~]# virt-install -n demo -r 1024 -f /tmp/demo.img -s 4 -c /dev/cdrom --nonetworks --debug
Tue, 13 Sep 2011 05:25:24 DEBUG    Launched with command line:
/usr/sbin/virt-install -n demo -r 1024 -f /tmp/demo.img -s 4 -c /dev/cdrom --nonetworks --debug
Tue, 13 Sep 2011 05:25:24 DEBUG    Requesting libvirt URI default
Tue, 13 Sep 2011 05:25:24 DEBUG    Received libvirt URI qemu:///system
Tue, 13 Sep 2011 05:25:24 DEBUG    Requesting virt method 'default', hv type 'default'.
Tue, 13 Sep 2011 05:25:24 DEBUG    Received virt method 'hvm'
Tue, 13 Sep 2011 05:25:24 DEBUG    Hypervisor name is 'kvm'
Tue, 13 Sep 2011 05:25:25 DEBUG    DISPLAY is set: graphics defaulting to VNC.
Tue, 13 Sep 2011 05:25:25 DEBUG    --graphics compat generated: vnc
Tue, 13 Sep 2011 05:25:25 DEBUG    DistroInstaller location is a local file/path: /dev/cdrom
Tue, 13 Sep 2011 05:25:25 ERROR    Values instance has no attribute 'macs'
Tue, 13 Sep 2011 05:25:25 DEBUG    Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 1004, in <module>
    sys.exit(main())
  File "/usr/sbin/virt-install", line 989, in main
    guest = build_guest_instance(conn, options)
  File "/usr/sbin/virt-install", line 530, in build_guest_instance
    check_option_collisions(options, guest)
  File "/usr/sbin/virt-install", line 393, in check_option_collisions
    if options.macs:
AttributeError: Values instance has no attribute 'macs'

      
Actual results:
see Steps to Reproduce:

Expected results:
no error,the installation will successful.

Additional info:
this bug not occur on
python-virtinst-0500.5-3.el6
libvirt-python-0.8.7-18.el6
it is a regression bug.

Comment 3 Cole Robinson 2011-09-22 15:42:59 UTC
Thanks for the report, fixed upstream:

http://git.fedorahosted.org/git?p=python-virtinst.git;a=commit;h=4b1b71b187faa18b6011809f9481a949bb54f772

Comment 4 Cole Robinson 2011-10-13 21:45:44 UTC
Fixed in python-virtinst-0.600.0-4.el6

Comment 7 Huming Jiang 2011-10-19 10:04:54 UTC
Reproduced with the following package:
python-virtinst-0.600.0-3.el6.noarch

Verified with
kernel-2.6.32-197.el6.x86_64
qemu-kvm-0.12.1.2-2.192.el6.x86_64
libvirt-0.9.4-17.el6.x86_64
python-virtinst-0.600.0-5.el6.noarch
virt-manager-0.9.0-7.el6.x86_64

step:
1.run command line:
[root@localhost ~]# virt-install -n demo -r 1024 -f /tmp/demo.img -s 4 -c
/dev/cdrom --nonetworks --debug

Wed, 19 Oct 2011 12:17:17 DEBUG    Launched with command line:
/usr/sbin/virt-install -n demo -r 1024 -f /tmp/demo.img -s 4 -c /dev/cdrom --nonetworks --debug
Wed, 19 Oct 2011 12:17:17 DEBUG    Requesting libvirt URI default
Wed, 19 Oct 2011 12:17:17 DEBUG    Received libvirt URI qemu:///system
Wed, 19 Oct 2011 12:17:17 DEBUG    Requesting virt method 'default', hv type 'default'.
Wed, 19 Oct 2011 12:17:17 DEBUG    Received virt method 'hvm'
Wed, 19 Oct 2011 12:17:17 DEBUG    Hypervisor name is 'kvm'
Wed, 19 Oct 2011 12:17:17 DEBUG    DISPLAY is set: graphics defaulting to VNC.
Wed, 19 Oct 2011 12:17:17 DEBUG    --graphics compat generated: vnc
Wed, 19 Oct 2011 12:17:17 DEBUG    DistroInstaller location is a local file/path: /dev/cdrom
Wed, 19 Oct 2011 12:17:17 DEBUG    Guest.has_install_phase: True

Starting install...
...

(The guest could be installed successfully without networks.)

So move the status of this bug to "verified".

Comment 8 Cole Robinson 2011-11-07 16:54:38 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary

Comment 9 errata-xmlrpc 2011-12-06 16:17:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1643.html


Note You need to log in before you can comment on or make changes to this bug.