Bug 738264 - LiberationMono have different metrics for different styles
LiberationMono have different metrics for different styles
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-14 08:38 EDT by Roman Kagan
Modified: 2011-10-09 15:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: liberation-fonts-1.07.1-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-29 19:28:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Kagan 2011-09-14 08:38:12 EDT
Description of problem:

LiberationMono Bold and Italic fonts have metrics different from Regular and BoldItalic.  This results in various artifacts, e.g. misaligned bold text in xterm or gnome-terminal at certain resolution and font size.

Version-Release number of selected component (if applicable):
liberation-mono-fonts-1.07.0-1.fc15.noarch

How reproducible:
100%

Steps to Reproduce:
1. using freetype-demos package:

# for f in /usr/share/fonts/liberation/LiberationMono-*; do
  ftdump $f | grep -e postscript -e ascent -e descent
done
   postscript: LiberationMono-BoldItalic
   ascent:          1705
   descent:         -615
   postscript: LiberationMono-Bold
   ascent:          1707
   descent:         -615
   postscript: LiberationMono-Italic
   ascent:          1707
   descent:         -615
   postscript: LiberationMono
   ascent:          1705
   descent:         -615

  
Actual results:

ascent for different styles is different.  As a result, at 106 dpi at size 10 pt the rounded ascent is different, too.  This makes bold characters misaligned in xterm and gnome-terminal (when used with freetype-2.4.6)

Expected results:

all metrics are the same

Additional info:

Full details are available in freetype bug https://savannah.nongnu.org/bugs/index.php?34156.

version 1.06 didn't have this problem.  It looks like it's due to the changes introduced to fix bug 591559.
Comment 1 Pravin Satpute 2011-09-15 03:27:27 EDT
Thanks for this info, i will fix and release this early next week.
Comment 2 Fedora Update System 2011-09-21 01:55:22 EDT
liberation-fonts-1.07.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.1-1.fc16
Comment 3 Fedora Update System 2011-09-21 18:15:24 EDT
Package liberation-fonts-1.07.1-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liberation-fonts-1.07.1-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.1-1.fc16
then log in and leave karma (feedback).
Comment 4 Roman Kagan 2011-09-22 02:38:07 EDT
1.07.1 looks fine, thanks!

Will you be updating f15 branch too?
Comment 5 Fedora Update System 2011-09-22 03:22:06 EDT
liberation-fonts-1.07.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.1-1.fc15
Comment 6 Pravin Satpute 2011-09-22 03:22:54 EDT
(In reply to comment #4)
> 1.07.1 looks fine, thanks!

Welcome!!
> 
> Will you be updating f15 branch too?

Done
Comment 7 Fedora Update System 2011-09-29 19:28:00 EDT
liberation-fonts-1.07.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2011-10-09 15:53:40 EDT
liberation-fonts-1.07.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.