Bug 73828 - pygtk package should have gsize patch applied to it
Summary: pygtk package should have gsize patch applied to it
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: pygtk2   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-11 18:35 UTC by Joe Shaw
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version: 1.99.14-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-20 04:29:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch file to apply. (386 bytes, patch)
2002-09-11 18:36 UTC, Joe Shaw
no flags Details | Diff

Description Joe Shaw 2002-09-11 18:35:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020606

Description of problem:
I have a patch in GNOME CVS which will go into pygtk 1.99.14 but which applies
cleanly to .12 and .13 to add support for "gsize" and "gssize" as valid integer
types.  Without this, the wrapper method for the gdk pixbuf loader's write()
method doesn't get generated, and you can't create pixmaps from in-memory data!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Call:

loader = gtk.gdk.gdk_pixbuf_loader_new()
loader.write(data, len(data))
loader.close()

Actual Results:  Traceback, because write() isn't defined.

Expected Results:  A pretty icon. :)

Additional info:

Here is the patch:

[joe@caedes ~]$ cat /usr/src/redhat/SOURCES/gsize.patch 
--- codegen/argtypes.py	Wed Jul 10 09:39:59 2002
+++ codegen/argtypes.py.joe	Fri Aug 23 16:33:07 2002
@@ -729,7 +729,8 @@
 matcher.register('long', arg)
 matcher.register('glong', arg)
 matcher.register('gboolean', arg)
-
+matcher.register('gsize', arg)
+matcher.register('gssize', arg)
 matcher.register('guint8', arg)
 matcher.register('gint8', arg)
 matcher.register('guint16', arg)

Comment 1 Joe Shaw 2002-09-11 18:36:02 UTC
Created attachment 75804 [details]
Patch file to apply.

Comment 2 Joe Shaw 2002-09-11 18:37:29 UTC
This is present in null too, obviously.  It would be very nice to have this
fixed for the next beta/release.  Also, you should probably upgrade to
1.99.13... i see the occassional crash in 1.99.12.


Comment 3 Matt Wilson 2002-09-13 04:13:42 UTC
this will make it in at some point...  dunno when.


Comment 4 Matt Wilson 2003-05-20 04:29:43 UTC
RHL 9 has 1.99.14



Note You need to log in before you can comment on or make changes to this bug.