Bug 738292 - thunderbird leaves thunderbird-bin zombie process
Summary: thunderbird leaves thunderbird-bin zombie process
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 13:47 UTC by Adam Tkac
Modified: 2018-04-11 16:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-24 12:53:02 UTC


Attachments (Terms of Use)

Description Adam Tkac 2011-09-14 13:47:46 UTC
Description of problem:
When I start thunderbird and it performs initial check for new mails, I see following in the process table:

15333 ?        Ssl    0:02              \_ /usr/lib64/thunderbird-6.0/thunderbird-bin
15348 ?        Z      0:00                  \_ [thunderbird-bin] <defunct>

The zombie process exists only after I terminate thunderbird.

Version-Release number of selected component (if applicable):
$ rpm -q thunderbird xulrunner
thunderbird-6.0.2-1.fc15.x86_64
xulrunner-6.0.2-1.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1. start thunderbird, it checks for new mails
2. run ps axf
  
Actual results:
thunderbird-bin zombie

Expected results:
no thunderbird zombies

Additional info:
Although the zombie doesn't cause any visible problem on my machine, it usually indicates that error handling in the program isn't good enough.

Comment 1 Matěj Cepl 2011-09-16 20:55:21 UTC
There are known bugs in Thunderbird with leaving zombie processes behind but apparently nobody knows what causes them.

Could you please take a look at 
https://wiki.mozilla.org/Thunderbird:Testing:Shutdown_Hang#Reported_Bugs and join the particular bug upstream? Please, if you do so, please, let us know so we can follow it as well and make sure the communication around the bug is alive.

Thank you

Comment 2 Wayne Mery (:wsmwk) 2011-10-23 12:35:00 UTC
Adam, did you discover more details about your issue from https://wiki.mozilla.org/Thunderbird:Testing:Shutdown_Hang ?

Comment 3 Adam Tkac 2011-10-24 12:53:02 UTC
Actually, I'm not able to reproduce this bug with the latest thunderbird-7.0.1-1.fc16.x86_64. I'm closing this ticket for now, will reopen it if I get more info. Thanks for the hints!


Note You need to log in before you can comment on or make changes to this bug.