Bug 738306 - File rename/remove exception
Summary: File rename/remove exception
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA
Version: 2.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Todd Sanders
QA Contact: mkovacik
URL:
Whiteboard:
Depends On:
Blocks: tracker-rhui-2.0.1
TreeView+ depends on / blocked
 
Reported: 2011-09-14 13:59 UTC by James Slagle
Modified: 2017-03-01 22:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Do not document
Clone Of:
Environment:
Last Closed: 2017-03-01 22:06:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0367 normal SHIPPED_LIVE Red Hat Update Infrastructure 3.0 Release 2017-03-02 03:05:22 UTC

Description James Slagle 2011-09-14 13:59:46 UTC
Seeing these 2 tracebacks in the grinder log:
2011-09-14 03:10:55,503 11105:140718655911680: grinder.BaseFetch:ERROR: activeobject:171 Caught exception<[Errno 2] No such file or directory> in fetch(xulrunner-1.9.2.18-2.el6_1.x86_64.rpm, https://cdn.redhat.com/content/dist/rhel/rhui/server/6/6.1/x86_64/os/Packages/xulrunner-1.9.2.18-2.el6_1.x86_64.rpm)
2011-09-14 03:10:55,507 11105:140718655911680: grinder.ParallelFetch:ERROR: ParallelFetch:337 Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/grinder/ParallelFetch.py", line 332, in run
    result = self.fetcher.fetchItem(itemInfo)
  File "/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 91, in __call__
    return self.object(self, *args, **kwargs)
  File "/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 284, in __call__
    return self.__call(method, args, kwargs)
  File "/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 260, in __call
    return self.__rmi(method.name, args, kwargs)
  File "/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 147, in __rmi
    raise Exception(ex)
Exception: Traceback (most recent call last):

  File "/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 446, in process
    retval = method(*args, **kwargs)

  File "/usr/lib/python2.6/site-packages/grinder/RepoFetch.py", line 116, in fetchItem
    packages_location=info['pkgpath'] or None)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 225, in fetch
    checksum, headers, retryTimes, packages_location)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 225, in fetch
    checksum, headers, retryTimes, packages_location)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 180, in fetch
    os.rename(tmp_write_file, filePath)

OSError: [Errno 2] No such file or directory


2011-09-14 03:10:55,509 11105:140718655911680: grinder.ParallelFetch:ERROR: ParallelFetch:338 Traceback (most recent call last):

  File "/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 446, in process
    retval = method(*args, **kwargs)

  File "/usr/lib/python2.6/site-packages/grinder/RepoFetch.py", line 116, in fetchItem
    packages_location=info['pkgpath'] or None)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 225, in fetch
    checksum, headers, retryTimes, packages_location)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 225, in fetch
    checksum, headers, retryTimes, packages_location)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 180, in fetch
    os.rename(tmp_write_file, filePath)

OSError: [Errno 2] No such file or directory


And:
2011-09-14 03:10:46,223 11105:140719136163584: grinder.BaseFetch:ERROR: activeobject:171 Retrying fetch of: xulrunner-1.9.2.18-2.el6_1.x86_64.rpm with 0 retry attempts left.
2011-09-14 03:10:46,224 11105:140718676891392: grinder.BaseFetch:ERROR: activeobject:171 Caught exception<[Errno 2] No such file or directory: '/var/lib/pulp//packages/valgrind/3.6.0/3.el6/x86_64/30c/valgrind-3.6.0-3.el6.x86_64.rpm'> in fetch(valgrind-3.6.0-3.el6.x86_64.rpm, https://cdn.redhat.com/content/dist/rhel/rhui/server/6/6Server/x86_64/os/Packages/valgrind-3.6.0-3.el6.x86_64.rpm)
2011-09-14 03:10:46,226 11105:140718645421824: grinder.BaseFetch:INFO: activeobject:171 Fetching 9619924 bytes: xulrunner-1.9.2.18-2.el6_1.i686.rpm from https://cdn.redhat.com/content/dist/rhel/rhui/server/6/6.1/x86_64/os/Packages/xulrunner-1.9.2.18-2.el6_1.i686.rpm
2011-09-14 03:10:46,228 11105:140718676891392: grinder.ParallelFetch:ERROR: ParallelFetch:337 Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/grinder/ParallelFetch.py", line 332, in run
    result = self.fetcher.fetchItem(itemInfo)
  File "/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 91, in __call__
    return self.object(self, *args, **kwargs)
  File "/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 284, in __call__
    return self.__call(method, args, kwargs)
  File "/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 260, in __call
    return self.__rmi(method.name, args, kwargs)
  File "/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 147, in __rmi
    raise Exception(ex)
Exception: Traceback (most recent call last):

  File "/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 446, in process
    retval = method(*args, **kwargs)

  File "/usr/lib/python2.6/site-packages/grinder/RepoFetch.py", line 116, in fetchItem
    packages_location=info['pkgpath'] or None)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 225, in fetch
    checksum, headers, retryTimes, packages_location)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 225, in fetch
    checksum, headers, retryTimes, packages_location)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 183, in fetch
    vstatus = self.validateDownload(filePath, int(itemSize), hashtype, checksum)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 66, in validateDownload
    os.remove(filePath)

OSError: [Errno 2] No such file or directory: '/var/lib/pulp//packages/valgrind/3.6.0/3.el6/x86_64/30c/valgrind-3.6.0-3.el6.x86_64.rpm'


2011-09-14 03:10:46,228 11105:140718676891392: grinder.ParallelFetch:ERROR: ParallelFetch:338 Traceback (most recent call last):

  File "/usr/lib/python2.6/site-packages/grinder/activeobject.py", line 446, in process
    retval = method(*args, **kwargs)

  File "/usr/lib/python2.6/site-packages/grinder/RepoFetch.py", line 116, in fetchItem
    packages_location=info['pkgpath'] or None)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 225, in fetch
    checksum, headers, retryTimes, packages_location)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 225, in fetch
    checksum, headers, retryTimes, packages_location)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 183, in fetch
    vstatus = self.validateDownload(filePath, int(itemSize), hashtype, checksum)

  File "/usr/lib/python2.6/site-packages/grinder/BaseFetch.py", line 66, in validateDownload
    os.remove(filePath)

OSError: [Errno 2] No such file or directory: '/var/lib/pulp//packages/valgrind/3.6.0/3.el6/x86_64/30c/valgrind-3.6.0-3.el6.x86_64.rpm'


Is it possible that since grinder is sync'ing multiple repos at the same time with the same content, other grinder threads are renaming/removing the temporary file out from underneath other threads?

Comment 1 Pradeep Kilambi 2011-09-14 16:17:22 UTC
fixed! commit cbb54e05ca9a73b982adc29a81a90e92ac5d4ff6

will require a need a new grinder build to test this.

Comment 2 wes hayutin 2011-10-17 20:01:41 UTC
set tracker bug. 746803

Comment 4 Sachin Ghai 2011-10-21 10:57:45 UTC
Verified this defect with following RHUI ISO:

RHEL-6.1-RHUI-2.0.1-20111017.0-Server-x86_64-DVD1.iso

[root@dhcp201-152 ~]# rpm -qa | grep grinder
grinder-0.0.120-1.el6.noarch
[root@dhcp201-152 ~]# 


I started the sync for multiple repos at once. Here is the repo list. But the reported issue is not reproducible with new RHUI ISO build.

Custom Repositories
  cus_sha1

Red Hat Repositories
  Red Hat Update Infrastructure 2.0 (RPMs) (6.0-i386)
  Red Hat Update Infrastructure 2.0 (RPMs) (6.1-i386)
  Red Hat Update Infrastructure 2.0 (RPMs) (6Server-i386)
  Red Hat Update Infrastructure 2.0 (RPMs) (6.0-x86_64)
  Red Hat Update Infrastructure 2.0 (RPMs) (6Server-x86_64)
  Red Hat Update Infrastructure 2.0 (RPMs) (6.1-x86_64)
  Red Hat Enterprise Linux Server 6 (RPMs) (6.0-i386)
  Red Hat Enterprise Linux Server 6 (RPMs) (6.0-x86_64)
  Red Hat Enterprise Linux Server 6 (RPMs) (6Server-x86_64)
  Red Hat Enterprise Linux Server 6 (RPMs) (6.1-x86_64)
  Red Hat Enterprise Linux Server 6 (RPMs) (6Server-i386)
  Red Hat Enterprise Linux Server 6 (RPMs) (6.1-i386)
  Red Hat Enterprise Linux Server 5 (RPMs) (5.6-i386)
  Red Hat Enterprise Linux Server 5 (RPMs) (5.7-i386)
  Red Hat Enterprise Linux Server 5 (RPMs) (5.6-x86_64)
  Red Hat Enterprise Linux Server 5 (RPMs) (5.7-x86_64)
  Red Hat Enterprise Linux Server 6 Optional (RPMs) (6.0-i386)
  Red Hat Enterprise Linux Server 6 Optional (RPMs) (6.0-x86_64)
  Red Hat Enterprise Linux Server 6 Optional (RPMs) (6Server-i386)
  Red Hat Enterprise Linux Server 6 Optional (RPMs) (6.1-x86_64)
  Red Hat Enterprise Linux Server 6 Optional (RPMs) (6Server-x86_64)
  Red Hat Enterprise Linux Server 6 Optional (RPMs) (6.1-i386)
  Red Hat Enterprise Linux Server 5 (RPMs) (5Server-i386)
  Red Hat Enterprise Linux Server 5 (RPMs) (5Server-x86_64)

Comment 5 James Slagle 2011-10-31 19:16:36 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Do not document

Comment 94 errata-xmlrpc 2017-03-01 22:06:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0367


Note You need to log in before you can comment on or make changes to this bug.