Bug 73832 - lpr fails to print to local printers after dhcp is turned on
lpr fails to print to local printers after dhcp is turned on
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-11 16:42 EDT by Ed Friedman
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 12:01:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Friedman 2002-09-11 16:42:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-10 i686)

Description of problem:
lpr fails to print to /dev/lp0 (even after making the correction to the
permissions of /dev/lp0) as soon as the /sbin/ifup eth0 command is given to
activate dhcp.  It prints to /dev/lp0 with no problems if dhcp is not activated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Set up a local printer with printtool.
2.Print to that printer to verify that it works.
3.Turn on dhcp (/sbin/ifup eth0), then try printing
	

Actual Results:  Printing fails (it tries to send the printjob to the dhcp
hostname, then complains that it doesn't exist)

Expected Results:  Printing should work

Additional info:
Comment 1 Tim Waugh 2003-01-20 13:52:47 EST
(Fixing component.)
Comment 2 Tim Waugh 2003-01-20 13:53:44 EST
Please attach the output of 'printconf-tui --Xexport'.
Comment 3 Tim Waugh 2005-09-16 12:01:04 EDT
We no longer ship LPRng.

Note You need to log in before you can comment on or make changes to this bug.