Bug 738322 - Katello returning inaccurate message via subscription-manager when user has incorrect credentials
Summary: Katello returning inaccurate message via subscription-manager when user has i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: Entitlement Bugs
URL:
Whiteboard:
Depends On:
Blocks: 738066 756082
TreeView+ depends on / blocked
 
Reported: 2011-09-14 14:38 UTC by Ivan Necas
Modified: 2012-06-20 13:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 13:03:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0804 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2012-06-19 19:51:31 UTC

Description Ivan Necas 2011-09-14 14:38:34 UTC
See Katello BZ (https://bugzilla.redhat.com/show_bug.cgi?id=736482)

When providing invalid credentials while system registration using subscription-manager against katello, there is an error:
 ERROR: Server does not support environments.

Expected result:
 Invalid Credentials

The problem is, subscription-manager tries to find out whether server supports environments, but doesn't checks if the request to katello was successful (katello returns 401 Unauthorized).

Comment 7 John Sefler 2012-03-16 19:23:24 UTC
Verifying Version....

candlepin-0.5.26-1.el6.noarch
katello-0.1.304-1.el6.noarch
[root@ibm-ls22-04 ~]# rpm -q subscription-manager
subscription-manager-0.99.10-1.el6.x86_64


[root@ibm-ls22-04 ~]# subscription-manager orgs --username admin --password BAD
Invalid credentials
[root@ibm-ls22-04 ~]# subscription-manager orgs --username admin
Password: 
+-------------------------------------------+
          admin Organizations
+-------------------------------------------+

Name: 	ACME_Corporation         
Key: 	ACME_Corporation         

Name: 	bbbbb                    
Key: 	bbbbb                    

[root@ibm-ls22-04 ~]# subscription-manager environments --org ACME_Corporation --username admin --password BAD
Invalid credentials
[root@ibm-ls22-04 ~]# subscription-manager environments --org ACME_Corporation --username admin
Password: 
+-------------------------------------------+
          Environments
+-------------------------------------------+
Name:                 	Library                  
Description:          	None                     

Name:                 	dev                      
Description:          	                         

Name:                 	qae                      
Description:          	                         

Name:                 	e2e                      
Description:          	                         

[root@ibm-ls22-04 ~]# subscription-manager register --org ACME_Corporation --environment dev --username admin --password BAD
Invalid credentials
[root@ibm-ls22-04 ~]# subscription-manager register --org ACME_Corporation --environment dev --username admin
Password: 
The system has been registered with id: 891b996c-2191-44aa-bd92-93659b4dd6ef 
[root@ibm-ls22-04 ~]# 


^^ VERIFIED: "Invalid Credentials" was given as feedback for subscription-manager modules orgs, environments, and register each time a BAD password was given.

moving to VERIFIED

Comment 9 errata-xmlrpc 2012-06-20 13:03:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html


Note You need to log in before you can comment on or make changes to this bug.