Bug 738323 - mvn3 fails to compile openhab
Summary: mvn3 fails to compile openhab
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: maven
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stanislav Ochotnicky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 14:40 UTC by Kevin Baker
Modified: 2014-12-01 23:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-16 16:19:52 UTC


Attachments (Terms of Use)
output from F15's maven `mvn3 clean install -X` (334.87 KB, application/octet-stream)
2011-09-14 14:40 UTC, Kevin Baker
no flags Details

Description Kevin Baker 2011-09-14 14:40:56 UTC
Created attachment 523167 [details]
output from F15's maven `mvn3 clean install -X`

Description of problem:

mvn3 on F15 fails to build openhab with "Equinox runtime location is missing or
invalid"



Version-Release number of selected component (if applicable):

maven-3.0.3-7.fc15.noarch : Java project management and project comprehension tool
Repo        : installed

How reproducible:

Steps to Reproduce:
 
1. rm -rf ~/.m2
2. hg clone -r d190dd74639b https://code.google.com/p/openhab/ openhab-d190dd74639b
3. cd openhab-d190dd74639b
4. mvn3 clean install -X

much output - see attached.

4. [ERROR] Internal error: java.lang.RuntimeException:
java.lang.RuntimeException: Equinox runtime location is missing or
invalid -> [Help 1]
org.apache.maven.InternalErrorException: Internal error:
java.lang.RuntimeException: java.lang.RuntimeException: Equinox
runtime location is missing or invalid

Compare with apache maven 3.0.3 - Same as above steps 1-3 but 

4. download maven from http://www.apache.org/dyn/closer.cgi/maven/binaries/apache-maven-3.0.3-bin.tar.gz
5. run with apache maven
=== SCRIPT ======================================
#!/bin/bash

MAVEN_PATH=/path/to/apache-maven-3.0.3
export PATH=$MAVEN_PATH/bin:$PATH
which mvn
rm -rf ~/.m2
cd openhab-d190dd74639b
mvn clean install -X
=== SCRIPT END ==================================

6. completes ok

  
Actual results:


Expected results:

F15 maven would work like the apache version

Additional info:

uname -a
Linux kyokushin 2.6.40.4-5.fc15.x86_64 #1 SMP Tue Aug 30 14:38:32 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Maven output at start of run:

Apache Maven 3.0.3 (rNON-CANONICAL_2011-06-28_15-20_mockbuild;
2011-06-28 11:20:31-0400)
Maven home: /usr/share/maven
Java version: 1.6.0_22, vendor: Sun Microsystems Inc.
Java home: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "2.6.40.4-5.fc15.x86_64", arch: "amd64",
family: "unix"

Comment 1 Stanislav Ochotnicky 2011-09-15 09:38:09 UTC
I have a hard time reproducing this on my F15 mixed with F16 and rawhide because with F15 maven version I almost always hit a certain JDK bug. Can you try maven version from rawhide? That seems to work OK for me, though it might require other updates (sisu, maybe jpackage-utils).

Simple "yum install --enable-repo=rawhide maven" should be sufficient though.

As a side note: F15 was a fairly big mess as far as Java packages are concerned, because we were doing a lot of overhauling in various areas, but we couldn't finish everything by the F15 deadline. Things should be much better in F16.

Comment 2 Kevin Baker 2011-09-16 14:04:39 UTC
Hi,

I'll wait for F16 ;-)

Comment 3 Stanislav Ochotnicky 2011-09-16 16:19:52 UTC
I just verified and indeed by installing maven and sisu from rawhide (identical to f16 currently), I was able to compile openhub. If you don't mind I'll close this bug as "NEXTRELEASE", because changes in Maven 3 between f15 and f16 are not cosmetic so I'd like to avoid any problems that would come from upgrading.

Thanks for the bugreport, at least I know we are making progress :-D

Comment 4 Kevin Baker 2011-09-16 18:30:15 UTC
no problem. thanks for checking.


Note You need to log in before you can comment on or make changes to this bug.