Bug 73837 - Mozilla input and autocompletion fails when ip address changes
Summary: Mozilla input and autocompletion fails when ip address changes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-11 21:27 UTC by Derek Atkins
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 07:49:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Atkins 2002-09-11 21:27:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
I'm running mozilla on a laptop.  When I suspend/resume and get a new IP
address, mozilla stops accepting input.  If I type C-L and start typing a URL in
the window, it will fail to autocomplete, and if I hit 'return' it will fail to
load the page.  Simiarly, if I type C-Shift-L to enter a URL via the dialog, I
cannot hit 'enter', or click on "open" or "cancel" -- the dialog will just sit
there and mozilla will not do anything.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run mozilla
2.suspend the laptop
3.resume the laptop in a location where I will obtain a different IP address
4. try to use the mozilla that was running before you suspended
	

Actual Results:  I cannot enter new URLs or autocomplete

Expected Results:  Mozilla should have continued to work properly.  I needed to
C-q (kill) and restart mozilla for it to work.  This is annoying when I want to
keep pages up across laptop movements.

Additional info:

Comment 1 Christopher Blizzard 2002-11-11 18:23:26 UTC
Are you sure that this is related to the change in IP address and not something
going wrong with the resume?

Comment 2 Derek Atkins 2002-11-11 18:39:53 UTC
Yes, because if I resume back to the same IP address it works just fine.


Comment 3 Warren Togami 2005-04-25 07:49:12 UTC
mozilla itself couldn't handle change of IP address anyway.  anyhow this was
probably fixed long ago.


Note You need to log in before you can comment on or make changes to this bug.