Bug 738377 - [abrt] yum-3.2.29-9.fc15: packages.py:1853:verify:UnboundLocalError: local variable 'mode' referenced before assignment
Summary: [abrt] yum-3.2.29-9.fc15: packages.py:1853:verify:UnboundLocalError: local va...
Keywords:
Status: CLOSED DUPLICATE of bug 671198
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c6d356d30948d374673612aac8e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 16:23 UTC by Bug Reporter
Modified: 2014-01-21 23:19 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-15 06:32:35 UTC


Attachments (Terms of Use)

Description Bug Reporter 2011-09-14 16:23:35 UTC
abrt version: 2.0.3
architecture:   i686
cmdline:        /usr/bin/python /usr/bin/yum verify-all
comment:        Don't know
component:      yum
executable:     /usr/bin/yum
kernel:         2.6.40.4-5.fc15.i686.PAE
os_release:     Fedora release 15 (Lovelock)
package:        yum-3.2.29-9.fc15
reason:         packages.py:1853:verify:UnboundLocalError: local variable 'mode' referenced before assignment
time:           Wed Sep 14 18:20:27 2011
uid:            500

backtrace:
:packages.py:1853:verify:UnboundLocalError: local variable 'mode' referenced before assignment
:
:Traceback (most recent call last):
:  File "/usr/bin/yum", line 29, in <module>
:    yummain.user_main(sys.argv[1:], exit_code=True)
:  File "/usr/share/yum-cli/yummain.py", line 267, in user_main
:    errcode = main(args)
:  File "/usr/share/yum-cli/yummain.py", line 120, in main
:    result, resultmsgs = base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 432, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/lib/yum-plugins/verify.py", line 363, in doCommand
:    self.show_data(base, msg, ypl.installed, 'Installed Packages')
:  File "/usr/lib/yum-plugins/verify.py", line 291, in show_data
:    for (pkg, results) in self.filter_data(msg, pkgs):
:  File "/usr/lib/yum-plugins/verify.py", line 208, in filter_data
:    callback=self.verify_callback)
:  File "/usr/lib/python2.7/site-packages/yum/packages.py", line 1853, in verify
:    mode    &= 0777
:UnboundLocalError: local variable 'mode' referenced before assignment
:
:Local variables in innermost frame:
:all: True
:my_user: 'root'
:digest_type: 'md5'
:verify_dev: False
:results: {'/usr/bin/acroread': [<yum.packages._PkgVerifyProb instance at 0xe28218c>]}
:fake_problems: True
:check_perms: False
:csum: 'md5:88f78285f3edddb28cffe12c2a9769a5'
:script: False
:self: <RPMInstalledPackage : AdobeReader_deu-9.4.2-1.i486 (0xe09638c)>
:csum_num: None
:fast: False
:patterns: None
:pf: <yum.packages._RPMVerifyPackageFile object at 0xe27870c>
:my_st_size: 19750L
:my_csum: 'md5:88f78285f3edddb28cffe12c2a9769a5'
:prob: <yum.packages._PkgVerifyProb instance at 0xe28216c>
:my_mode: 511
:csum_type: 'md5'
:problems: [<yum.packages._PkgVerifyProb instance at 0xe28216c>]
:verify_digest: True
:pfs: <yum.packages._RPMVerifyPackage instance at 0xe1f3c8c>
:ftypes: ['ghost']
:fi: <rpm.fi object at 0x8f91da0>
:fn: '/usr/bin/acroread'
:have_prelink: True
:my_st: posix.stat_result(st_mode=41471, st_ino=1709697L, st_dev=64769L, st_nlink=1, st_uid=0, st_gid=0, st_size=31L, st_atime=1316017109, st_mtime=1298814198, st_ctime=1298814198)
:my_ftype: 'symlink'
:my_group: 'root'
:check_content: False
:callback: <bound method YumBaseCli.verify_plugins_cb of <cli.YumBaseCli object at 0xb728c6ec>>
:my_fnl: '/opt/Adobe/Reader9/bin/acroread'
:deps: False
:prelink_cmd: '/usr/sbin/prelink'

Comment 1 Zdeněk Pavlas 2011-09-15 06:32:35 UTC

*** This bug has been marked as a duplicate of bug 671198 ***


Note You need to log in before you can comment on or make changes to this bug.