Bug 738382 - ath9x driver crashes during session, requires reboot
ath9x driver crashes during session, requires reboot
Status: CLOSED DUPLICATE of bug 736435
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-14 12:42 EDT by Alex Markley
Modified: 2011-10-17 11:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-17 11:22:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Markley 2011-09-14 12:42:50 EDT
Description of problem:

Got a new ASUS UL80J laptop with an Atheros WiFi chipset. WiFi works out of the box, HOWEVER, after some time the chip and/or driver crashes, terminating any network connections and making WiFi unavailable.

After this "crash", nothing I do will bring the device back online. Suspend/resume does not work, unloading and reloading the modules does not work. Only a full reboot will bring the WiFi device back to life.

Version-Release number of selected component (if applicable):

2.6.40.4-5.fc15.i686.PAE

How reproducible:

Very reproducible.

Steps to Reproduce:
1. Load Fedora 15 on ASUS UL80J.
2. Use WiFi for a few hours.
3. Observe failure.
  
Actual results:

WiFi suddenly becomes unavailable.

Expected results:

WiFi shouldn't crash unexpectedly. It really should work.

Additional info:

[root@curmudgeon ~]# uname -a
Linux curmudgeon.malexmedia.net 2.6.40.4-5.fc15.i686.PAE #1 SMP Tue Aug 30 14:43:52 UTC 2011 i686 i686 i386 GNU/Linux

[root@curmudgeon ~]# lspci | grep -i net
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
04:00.0 Ethernet controller: Atheros Communications AR8131 Gigabit Ethernet (rev c0)

This shows up hundreds of times:

Sep 13 23:18:27 curmudgeon kernel: [49182.066910] ath: Unable to reset channel (2447 MHz), reset status -22
Sep 13 23:18:27 curmudgeon kernel: [49182.162911] ath: Failed to stop TX DMA!
Sep 13 23:18:27 curmudgeon kernel: [49182.175864] ath: DMA failed to stop in 10 ms AR_CR=0xffffffff AR_DIAG_SW=0xffffffff DMADBG_7=0xffffffff
Sep 13 23:18:27 curmudgeon kernel: [49182.175869] ath: Could not stop RX, we could be confusing the DMA engine when we start RX up
Sep 13 23:18:28 curmudgeon kernel: [49182.291949] ath: Chip reset failed
Sep 13 23:18:28 curmudgeon kernel: [49182.291956] ath: Unable to reset channel (2412 MHz), reset status -22
Sep 13 23:18:28 curmudgeon kernel: [49182.291982] ath: Unable to set channel
Sep 13 23:18:28 curmudgeon kernel: [49182.357672] ath: Failed to stop TX DMA!
Sep 13 23:18:28 curmudgeon kernel: [49182.370615] ath: DMA failed to stop in 10 ms AR_CR=0xffffffff AR_DIAG_SW=0xffffffff DMADBG_7=0xffffffff
Sep 13 23:18:28 curmudgeon kernel: [49182.370622] ath: Could not stop RX, we could be confusing the DMA engine when we start RX up
Sep 13 23:18:28 curmudgeon kernel: [49182.486823] ath: Chip reset failed
Sep 13 23:18:28 curmudgeon kernel: [49182.486830] ath: Unable to reset channel (2417 MHz), reset status -22
Sep 13 23:18:28 curmudgeon kernel: [49182.486854] ath: Unable to set channel
Sep 13 23:18:28 curmudgeon kernel: [49182.552407] ath: Failed to stop TX DMA!
Sep 13 23:18:28 curmudgeon kernel: [49182.565360] ath: DMA failed to stop in 10 ms AR_CR=0xffffffff AR_DIAG_SW=0xffffffff DMADBG_7=0xffffffff
Sep 13 23:18:28 curmudgeon kernel: [49182.565365] ath: Could not stop RX, we could be confusing the DMA engine when we start RX up
Sep 13 23:18:28 curmudgeon kernel: [49182.681664] ath: Chip reset failed

After the chip "crashes", here's what happens when you try to wake the system from suspend:

Sep 14 12:00:11 curmudgeon NetworkManager[847]: <info> wake requested (sleeping: yes  enabled: yes)
Sep 14 12:00:11 curmudgeon NetworkManager[847]: <info> waking up and re-enabling...
Sep 14 12:00:11 curmudgeon NetworkManager[847]: <info> (wlan0): now managed
Sep 14 12:00:11 curmudgeon NetworkManager[847]: <info> (wlan0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Sep 14 12:00:11 curmudgeon NetworkManager[847]: <info> (wlan0): bringing up device.
Sep 14 12:00:11 curmudgeon kernel: [49394.749934] ath: Failed to wakeup in 500us
Sep 14 12:00:11 curmudgeon NetworkManager[847]: <info> (wlan0): deactivating device (reason: 2).
Sep 14 12:00:11 curmudgeon kernel: [49394.867387] ath: Chip reset failed
Sep 14 12:00:11 curmudgeon kernel: [49394.867394] ath: Unable to reset hardware; reset status -22 (freq 2447 MHz)

After rmmod'ing all ath* modules and reloading with modprobe ath9x:

Sep 14 12:07:25 curmudgeon kernel: [49828.065833] ath9k 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
Sep 14 12:07:25 curmudgeon kernel: [49828.182642] ath: Couldn't reset chip
Sep 14 12:07:25 curmudgeon kernel: [49828.182647] ath: Unable to initialize hardware; initialization status: -5
Sep 14 12:07:25 curmudgeon kernel: [49828.182655] ath9k 0000:03:00.0: Failed to initialize device
Sep 14 12:07:25 curmudgeon kernel: [49828.182710] ath9k 0000:03:00.0: PCI INT A disabled
Sep 14 12:07:25 curmudgeon kernel: [49828.182765] ath9k: probe of 0000:03:00.0 failed with error -5
Comment 1 Paul Gössinger 2011-09-16 14:41:11 EDT
I have the same issue on my x86 netbook with the same Atheros chipset and Kernel version.
However not even a reboot fixes this issue for me, so I dont have a WiFi connection at the moment :(
Comment 2 John W. Linville 2011-10-17 11:22:21 EDT

*** This bug has been marked as a duplicate of bug 736435 ***

Note You need to log in before you can comment on or make changes to this bug.