Bug 7384 - KickStart Fails
KickStart Fails
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-27 21:59 EST by adaniels
Modified: 2015-01-07 18:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-09 09:23:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adaniels 1999-11-27 21:59:59 EST
I work for a company that has plans on deploying >500 Linux Redhat servers
and I *NEED* to automate this.  I saw the nifty KickStart-HOWTO and read
it throughly.  It does NOT work with the latest bootnet.img.  Here's the
steps I've followed:

  o Grabbed a new 3 1/2 floppy disk, formatted it under windows
  o grabbed rawrite.exe from ftp.redhat.com
  o grabbed bootnet.img from ftp.redhat.com in the updates dir
  o rawrite bootnet.img a:
  o created a ks.cfg based off of ks.samp found on ftp.redhat.com
  o copied using windows ks.cfg to a:
  o checked to see that ks.cfg was on the floppy, along with initrd.img,
    syslinux.cfg, 6 messages, ldlinux.sys and vmlinuz
  o put the floppy into the drive of the system I wanted to build,
    made sure there was no cdrom in the drive (wanting to do a network
    based build).
  o booted said PC
  o watched it do mem check, come up with the boot.msg (which I modified
    so I'd know for sure that it came up with my boot disk).
  o typed in:    linux ks=floppy
  o waited for it to boot.. it runs through initrd.img and vmlinuz and
    when it finally comes up it's asking me to choose a language which
    I've already predefined in the ks.cfg.   Now I've also tried other
    things like modifying the syslinux.cfg to have the above parameters
    just like the howto states and that's produce negative results.

Is there another, easier way to do this?  I don't want to spend weeks on
this it's too windows like to spend that much time.. please oh please help
me.


Here's my ks.cfg


          -------------------------------------------------

# eventually, we'll allow cdrom kickstarts
network --dhcp
#network --static  --ip 172.16.9.33 --netmask 255.255.255.0 --gateway
172.16.9.1 --nameserver 216.148.237.95
nfs --server 172.16.9.35 --dir /scratch/
# keymap to use, same as keymap named in kbdconfig
keyboard us
# Disk partitioning stuff goes here. It also sets up the fstab stuff
# and selects which partitions are formatted. All swap partitions are
# formatted and used though.
# this should be install or upgrade, defaults to 'install' if omitted
# install
# it would be nice if we could setup networking parameters for installs
# which weren't bootpd :-(
# printer configuration goes here
# mouse types are: ps/2 mousesystems microsoft logitech atibm logibm msbm
# the default device is right for busmice, /dev/cua0 for serial mice, and
# can be overridden with "--device cua2"
# if three button emulation is needed, specify "--emulthree"
#
# this is just like /usr/sbin/mouseconfig
mouse ps/2 --emulthree
# the timezone command takes the same args as /usr/sbin/timeconfig
# see the timeconfig 2.0 man page for details
timezone --utc US/Pacific
# xconfiguration
#   Video card selection:
#       You can let it try to find you PCI card automatically, OR
#       specify --card <cardtype> (see Xconfigurator --help for list), OR
#       specify --server <servertype> (also see Xconfigurator --help)
#
#   Monitor selection:
#       If none specified, assumes 640x480@60hz.
#       Otherwise, use --monitor <type>, see Xconfigurator --help for
list, OR
#       use --hsync <hsync> and --vsync <vsync>. For example:
#          --hsync "31.5,35.5,50-65" --vsync "50-70"
#
#
#xconfig --monitor "ViewSonic 15"
# this root password goes over the network in the clear for NFS kickstarts
# it's probably a good idea not to use the real root password here
#
# if the password is already crypted (and suitable for inclusion in
# /etc/passwd without further editing), use the iscrypted flag. this
# should be used to prevent a cleartext root password from going over
# the network
rootpw N3tL3dG3r
# lilo install goes to mbr by default w/ no append line. you can modify
# this as shown in the example
#    lilo --append "mem=128M" --location mbr
# the location is one of mbr (default), none, or partition
# this command is called 'silo' on the sparc, and doesn't exist on the
alpha
#
# zerombr yes|no
#
# Should the install automatically zero the partition table if it is
corrupt?
#
zerombr yes
#
# clearpart - requires --all or --linux
#
# --all   removes everything from ALL DRIVES
# --linux removes all linux native/swap from ALL DRIVES
#
clearpart --linux
#
# part <mntpt> --size <size in megs> [--grow] [--maxsize <size in megs>]
#
part / --size 1536
part swap --size 1536
part /opt --size 1024 --grow
# packges to install follow here
# '@ component' may be used to include entire components, redundant items
# are okay
%packages
@ Base
@ NetLedgerExtras
tcp_wrappers
traceroute
Comment 1 Jay Turner 2000-02-09 09:23:59 EST
There is not a "lang" variable in the ks.cfg file that you submitted above.
This is the reason that the installer is asking for the language.

Note You need to log in before you can comment on or make changes to this bug.