Bug 738430 - Property list displayed by 'qemu-kvm -device pci-assign,\?' is not complete
Summary: Property list displayed by 'qemu-kvm -device pci-assign,\?' is not complete
Keywords:
Status: CLOSED DUPLICATE of bug 678731
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 738388
TreeView+ depends on / blocked
 
Reported: 2011-09-14 18:45 UTC by Nandini Chandra
Modified: 2011-09-20 09:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-20 09:05:27 UTC


Attachments (Terms of Use)

Description Nandini Chandra 2011-09-14 18:45:27 UTC
Description of problem:
The property list displayed by 'qemu-kvm -device pci-assign,\?' is not complete.
For eg:It does not list the multifunction property.

$/usr/libexec/qemu-kvm -device pci-assign,\?
pci-assign.host=pci-hostaddr
pci-assign.iommu=on/off
pci-assign.prefer_msi=on/ofproperty list displayed by 'qemu-kvm -device pci-assign,\?' is not completef
pci-assign.bootindex=int32
pci-assign.configfd=string


Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.189.el6.x86_64.rpm

How reproducible:
Always

Steps to Reproduce:
1.Run $/usr/libexec/qemu-kvm -device pci-assign,\? and notice that the multifunction property does not get listed.
2.
3.
  
Actual results:


Expected results:
'qemu-kvm -device pci-assign,\?' should display the multifunction property.

Additional info:

Comment 1 Nandini Chandra 2011-09-14 19:02:59 UTC
Since 'qemu-kvm -device pci-assign,\?' does not display the multifunction
property,libvirt has to revert to version hacks to detect PCI multifunction
support.

Refer to https://bugzilla.redhat.com/show_bug.cgi?id=738388.

Comment 2 Markus Armbruster 2011-09-20 08:18:17 UTC
Fixed upstream in commit a8467c7a.  Reassigning bug to the upstream fixer.

Comment 3 Gerd Hoffmann 2011-09-20 09:05:27 UTC

*** This bug has been marked as a duplicate of bug 678731 ***


Note You need to log in before you can comment on or make changes to this bug.