Bug 738441 - SELinux is preventing /usr/bin/wine-preloader from mmap_zero access on the memprotect Unknown
Summary: SELinux is preventing /usr/bin/wine-preloader from mmap_zero access on the me...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 19:32 UTC by Marcin Zajaczkowski
Modified: 2011-09-15 13:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-15 13:37:26 UTC


Attachments (Terms of Use)
SELinux alert (3.46 KB, text/plain)
2011-09-14 19:33 UTC, Marcin Zajaczkowski
no flags Details

Description Marcin Zajaczkowski 2011-09-14 19:32:11 UTC
Description of problem:
SELinux is preventing /usr/bin/wine-preloader from mmap_zero access on the memprotect Unknown.

Version-Release number of selected component (if applicable):
wine-1.3.24-1.fc15.x86_64
selinux-policy-3.9.16-38.fc15.noarch

How reproducible:
Always

Steps to Reproduce:
1. winecfg
2. cd ~/.wine/drive_c/windows
3. wine notepad.exe (or something else)
  
Actual results:
Notepad is started, but SELinux alert is also shown.

Expected results:
No SELinux alert

Additional info:
Tested also with new created .wine directory. Similar to bug 666363, but it should be fixed a few versions ago.

Comment 1 Marcin Zajaczkowski 2011-09-14 19:33:13 UTC
Created attachment 523239 [details]
SELinux alert

Comment 2 Daniel Walsh 2011-09-15 13:37:26 UTC
The alert explains that this access is dangerous and you can turn off the check if you want.  We will not fix it, since we believe this is a fundamental problem with running windows apps on a linux box.


Note You need to log in before you can comment on or make changes to this bug.