Bug 738463 - cpuspeed init script still tries to adjust cpufreq sysfiles on a per core basis
Summary: cpuspeed init script still tries to adjust cpufreq sysfiles on a per core basis
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cpuspeed
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Petr Šabata
QA Contact: John Brier
URL:
Whiteboard:
Depends On:
Blocks: 767187 836169
TreeView+ depends on / blocked
 
Reported: 2011-09-14 21:04 UTC by Travis Gummels
Modified: 2018-11-29 21:45 UTC (History)
3 users (show)

Fixed In Version: cpuspeed-1.5-18.el6
Doc Type: Bug Fix
Doc Text:
Cause: The cpuspeed init script still tries to adjust cpufreq sysfiles on a per core basis eventhough the cpufreq drivers complain that this is a deprecated procedure. Consequence: The log files are full of warnings. Fix: Tresholds are set globally, instead of deprecated per unit setting. Result: No warnings in dmesg. Tresholds are set globally on all cpus.
Clone Of:
Environment:
Last Closed: 2012-10-25 13:11:09 UTC


Attachments (Terms of Use)
Set thresholds globally instead of per CPU (530 bytes, patch)
2011-09-15 10:05 UTC, Petr Šabata
no flags Details | Diff
Init file for cpuspeed at customer site. (11.53 KB, application/octet-stream)
2011-09-26 21:04 UTC, Travis Gummels
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1404 normal SHIPPED_LIVE cpuspeed bug fix update 2012-10-25 17:08:38 UTC

Description Travis Gummels 2011-09-14 21:04:02 UTC
Description of problem:

The cpuspeed init script still tries to adjust cpufreq sysfiles on a per core 
basis eventhough the cpufreq drivers complain that that is a deprecated 
procedure.  We see the following in dmesg:
  
  "CPUFREQ: Per core ondemand sysfs interface is deprecated - up_threshold"

LLNL is currently working on an issue with Intel and are seeing the dmesg output is getting muddied with these messages as slurm restarts and stops cpuspeed between jobs.

Version-Release number of selected component (if applicable):
cpuspeed-1.5-15.el6.x86_64
kernel-2.6.32-131.4.1.1chaos.ch5.x86_64

How reproducible:
100

Steps to Reproduce:
Set a specific UP_THRESHOLD value in /etc/sysconfig/cpuspeed
Start and stop cpuspeed.

Actual results:
Lots of messages.

Expected results:
None.

Additional info:

Comment 1 Petr Šabata 2011-09-15 10:05:08 UTC
Created attachment 523338 [details]
Set thresholds globally instead of per CPU

Comment 2 Petr Šabata 2011-09-15 10:05:55 UTC
The attached patch should fix the issue.
Requesting acks.

Comment 8 Travis Gummels 2011-09-26 21:04:03 UTC
Created attachment 524993 [details]
Init file for cpuspeed at customer site.

Comment 23 John Brier 2012-09-26 18:40:40 UTC
Original problem reproduced:

[root@amd-annapurna-02 ~]# rpm -q cpuspeed 
cpuspeed-1.5-15.el6.x86_64
[root@amd-annapurna-02 ~]# egrep ^UP /etc/sysconfig/cpuspeed 
UP_THRESHOLD=30
[root@amd-annapurna-02 ~]# service cpuspeed restart
Disabling ondemand cpu frequency scaling:                  [  OK  ]
Enabling ondemand cpu frequency scaling:                   [  OK  ]
[root@amd-annapurna-02 ~]# dmesg | grep CPUFREQ
CPUFREQ: Per core ondemand sysfs interface is deprecated - up_threshold
CPUFREQ: Per core ondemand sysfs interface is deprecated - up_threshold
[root@amd-annapurna-02 ~]# 

Latest version of cpuspeed in errata doesn't produce additional CPUFREQ warning/error but it does have the same error the customer reported in comment 7:

[root@amd-annapurna-02 ~]# rpm -Uvh cpuspeed-1.5-17.el6.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:cpuspeed               ########################################### [100%]
[root@amd-annapurna-02 ~]# service cpuspeed restart
Disabling ondemand cpu frequency scaling:                  [  OK  ]
/etc/init.d/cpuspeed: line 86: cpufreq/ondemand/up_threshold: No such file or directory
Enabling ondemand cpu frequency scaling:                   [  OK  ]
[root@amd-annapurna-02 ~]# dmesg | grep CPUFREQ
CPUFREQ: Per core ondemand sysfs interface is deprecated - up_threshold
CPUFREQ: Per core ondemand sysfs interface is deprecated - up_threshold

Is the error from the init script expected?

Comment 24 John Brier 2012-10-02 14:47:30 UTC
(In reply to comment #23)
> Is the error from the init script expected?

Petr can you respond to the above comment?

Comment 25 Petr Šabata 2012-10-05 13:44:47 UTC
(In reply to comment #24)
> (In reply to comment #23)
> > Is the error from the init script expected?
> 
> Petr can you respond to the above comment?

Hmm, I see the changes pushed here come from the original (not working) patch I posted last year.  I posted an updated version in Comment 12, however there was no feedback back then and both the test SRPM and the patch are not available anymore.  I hope to find it somewhere on my system :)

This bug was not fixed in 1.5-17.  I'd suggest FailedQA for now.

Comment 33 errata-xmlrpc 2012-10-25 13:11:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1404.html


Note You need to log in before you can comment on or make changes to this bug.