Bug 73847 - Kickstart FTP install fails with Compaq Deskpro EN (eepro100)
Kickstart FTP install fails with Compaq Deskpro EN (eepro100)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-12 01:01 EDT by James Hine
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 09:14:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Hine 2002-09-12 01:01:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT)

Description of problem:
During an FTP kickstart installation, the eepro100 driver will fail (timeout) 
causing the installation to time out (error message displayed on TTY4 and 5) 
is "eepro100: wait_for_cmd_done timeout!"

The occurence of this fault appears to occur during periods of low network 
utilization.  Both the FTP and client systems reside in seperate VLAN's within 
a fully switched network and auto-negotiate to 100TxFD.  When the FTP server is 
under load, the problem is not reproducable, however it is not specific to a 
single client system - the issue has occured across 4 different Deskpro EN 
systems. 

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
This works in our office

1. Wait for quiet network (after business hours)
2. Start install
3. Wait for it to fail. ;)
	

Actual Results:  Had to restart the installation.

Additional info:

Client:
Compaq DP EN SFF 1.0 Ghz 512mb RAM.
Boot image floppy.

Server:
M$ FTP server.

Other stuff: 

Will sometime recover after 15-30 minutes, and install will complete. 

Have looked around the tty2 while it is failing, it will not ping any known to 
be good IP addresses.  

Poked around the /proc system and could not see anything untoward.
Comment 1 Michael Fulbright 2002-09-13 17:14:29 EDT
Appears to be a kernel drive issue.
Comment 2 Arjan van de Ven 2002-10-07 04:05:35 EDT
does using the e100 driver instead help ?
(the eepro100 driver seems to not have a hardware workaround for an interaction
with one specific type of cisco switch while using half duplex ;( )
Comment 3 James Hine 2002-11-05 21:55:32 EST
Using the latest intel e100 driver appears to help will continue to test. This 
will not help with automated KS installs.

Note You need to log in before you can comment on or make changes to this bug.