Bug 738493 - arch_default_crash_size has bad calculation
Summary: arch_default_crash_size has bad calculation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.1
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pratyush Anand
QA Contact: Emma Wu
URL:
Whiteboard:
Depends On:
Blocks: 1359574 1366045
TreeView+ depends on / blocked
 
Reported: 2011-09-15 00:12 UTC by Wayne H. Badger
Modified: 2016-09-05 20:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-16 02:55:49 UTC


Attachments (Terms of Use)

Description Wayne H. Badger 2011-09-15 00:12:50 UTC
Description of problem:
The arch_default_crash_size function in kernel/kexec.c tries to figure out the automatic size to use for the crashkernel.  The existing calculation turns out to be independent of the system_ram -- it's always 135266304 (129M) for any reasonable values of system_ram.

A comment in the code indicates that the calculation is meant to use a 1:8192 ratio.  This could be done by changing the (1ULL<<23) to (1ULL<<13).

It's not clear that this should be the calculation or if it should be something else.  Larger memory systems will certainly consume more slab space and result in the 70% warning when running mkdumprd.


Version-Release number of selected component (if applicable):
2.6.32-131.0.15.el6


How reproducible:
100%


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 RHEL Product and Program Management 2011-10-07 15:48:15 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 3 Qiao Zhao 2016-08-02 08:34:50 UTC
Hi kdump developer, 

Any update for this bug?

--
Thanks,
Qiao

Comment 4 Pratyush Anand 2016-08-09 03:07:36 UTC
(In reply to Wayne H. Badger from comment #0)
> It's not clear that this should be the calculation or if it should be
> something else.  Larger memory systems will certainly consume more slab
> space and result in the 70% warning when running mkdumprd.

Hi,

Please let us know a use-case or reproducer where we can reproduce warning when running mkdumprd with current crash size allocation scheme.

~Pratyush

Comment 7 Pratyush Anand 2016-08-16 02:55:49 UTC
Closing , because it is working in current release as per comment 6.

Comment 8 Wayne H. Badger 2016-08-31 19:18:54 UTC
The main part of this ticket was fixed in 2011.  In the 5 years since this ticket was created, we have not noticed additional issues with kdump related to this ticket.


Note You need to log in before you can comment on or make changes to this bug.