Bug 738499 - Failed to start LXC domain error: Unknown failure
Summary: Failed to start LXC domain error: Unknown failure
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.1
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Osier Yang
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-15 02:07 UTC by gregrwm
Modified: 2018-11-26 18:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-23 03:10:23 UTC


Attachments (Terms of Use)

Description gregrwm 2011-09-15 02:07:47 UTC
Description of problem:
i must be missing something

Version-Release number of selected component (if applicable):
libvirt-0.8.7-18.el6_1.1.x86_64

Steps to Reproduce:
1.  yum install libvirt libvirt-client
2.  start libvirtd
3.  enter first example at http://libvirt.org/drvlxc.html
4.  virsh --connect lxc:/// define vm1.xml
5.  virsh --connect lxc:/// start vm1

Actual results:
Domain mycontainer defined from vm1.xml

error: Failed to start domain vm1
error: Unknown failure

/var/log/messages contains nothing recent despite claim here:
http://wiki.libvirt.org/page/FAQ#error:_Unknown_Failure

Comment 2 Osier Yang 2011-09-15 02:44:01 UTC
(In reply to comment #0)
> Description of problem:
> i must be missing something
> 
> Version-Release number of selected component (if applicable):
> libvirt-0.8.7-18.el6_1.1.x86_64
> 
> Steps to Reproduce:
> 1.  yum install libvirt libvirt-client
> 2.  start libvirtd
> 3.  enter first example at http://libvirt.org/drvlxc.html
> 4.  virsh --connect lxc:/// define vm1.xml
> 5.  virsh --connect lxc:/// start vm1
> 
> Actual results:
> Domain mycontainer defined from vm1.xml
> 
> error: Failed to start domain vm1
> error: Unknown failure
> 
> /var/log/messages contains nothing recent despite claim here:
> http://wiki.libvirt.org/page/FAQ#error:_Unknown_Failure

The debug log may has something useful to track though. E.g.

log_level=1
log_outputs="1:file:/tmp/debug.log"

Comment 3 gregrwm 2011-09-15 03:29:11 UTC
#  LIBVIRT_DEBUG=1 virsh --connect lxc:/// start vm1
22:22:08.204: 27276: info : libvirt version: 0.8.7, package: 18.el6_1.1 (Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>, 2011-08-08-05:23:02, x86-012.build.bos.redhat.com)
22:22:08.204: 27276: debug : virInitialize:377 : register drivers
22:22:08.204: 27276: debug : virRegisterDriver:985 : registering Test as driver 0
22:22:08.204: 27276: debug : virRegisterNetworkDriver:791 : registering Test as network driver 0
22:22:08.204: 27276: debug : virRegisterInterfaceDriver:822 : registering Test as interface driver 0
22:22:08.204: 27276: debug : virRegisterStorageDriver:853 : registering Test as storage driver 0
22:22:08.204: 27276: debug : virRegisterDeviceMonitor:884 : registering Test as device driver 0
22:22:08.204: 27276: debug : virRegisterSecretDriver:915 : registering Test as secret driver 0
22:22:08.204: 27276: debug : virRegisterNWFilterDriver:946 : registering Test as network filter driver 0
22:22:08.204: 27276: debug : virRegisterDriver:985 : registering ESX as driver 1
22:22:08.204: 27276: debug : virRegisterInterfaceDriver:822 : registering ESX as interface driver 1
22:22:08.204: 27276: debug : virRegisterNetworkDriver:791 : registering ESX as network driver 1
22:22:08.204: 27276: debug : virRegisterStorageDriver:853 : registering ESX as storage driver 1
22:22:08.204: 27276: debug : virRegisterDeviceMonitor:884 : registering ESX as device driver 1
22:22:08.204: 27276: debug : virRegisterSecretDriver:915 : registering ESX as secret driver 1
22:22:08.204: 27276: debug : virRegisterNWFilterDriver:946 : registering ESX as network filter driver 1
22:22:08.204: 27276: debug : virRegisterDriver:985 : registering remote as driver 2
22:22:08.204: 27276: debug : virRegisterNetworkDriver:791 : registering remote as network driver 2
22:22:08.204: 27276: debug : virRegisterInterfaceDriver:822 : registering remote as interface driver 2
22:22:08.204: 27276: debug : virRegisterStorageDriver:853 : registering remote as storage driver 2
22:22:08.204: 27276: debug : virRegisterDeviceMonitor:884 : registering remote as device driver 2
22:22:08.204: 27276: debug : virRegisterSecretDriver:915 : registering remote as secret driver 2
22:22:08.204: 27276: debug : virRegisterNWFilterDriver:946 : registering remote as network filter driver 2
22:22:08.204: 27276: debug : virConnectOpenAuth:1560 : name=lxc:///, auth=0x309bd707a0, flags=0
22:22:08.206: 27276: debug : do_open:1266 : name "lxc:///" to URI components:
  scheme lxc
  opaque (null)
  authority (null)
  server (null)
  user (null)
  port 0
  path /

22:22:08.206: 27276: debug : do_open:1305 : trying driver 0 (Test) ...
22:22:08.206: 27276: debug : do_open:1311 : driver 0 Test returned DECLINED
22:22:08.206: 27276: debug : do_open:1305 : trying driver 1 (ESX) ...
22:22:08.206: 27276: debug : do_open:1311 : driver 1 ESX returned DECLINED
22:22:08.206: 27276: debug : do_open:1305 : trying driver 2 (remote) ...
22:22:08.206: 27276: debug : doRemoteOpen:580 : proceeding with name = lxc:///
22:22:08.207: 27276: debug : remoteIO:10407 : Do proc=66 serial=0 length=28 wait=(nil)
22:22:08.207: 27276: debug : remoteIO:10479 : We have the buck 66 0x7f6e20a81010 0x7f6e20a81010
22:22:08.208: 27276: debug : remoteIODecodeMessageLength:9803 : Got length, now need 64 total (60 more)
22:22:08.208: 27276: debug : remoteIOEventLoop:10333 : Giving up the buck 66 0x7f6e20a81010 (nil)
22:22:08.209: 27276: debug : remoteIO:10507 : All done with our call 66 (nil) 0x7f6e20a81010
22:22:08.209: 27276: debug : remoteIO:10407 : Do proc=1 serial=1 length=48 wait=(nil)
22:22:08.209: 27276: debug : remoteIO:10479 : We have the buck 1 0xb4c740 0xb4c740
22:22:08.223: 27276: debug : remoteIODecodeMessageLength:9803 : Got length, now need 56 total (52 more)
22:22:08.223: 27276: debug : remoteIOEventLoop:10333 : Giving up the buck 1 0xb4c740 (nil)
22:22:08.223: 27276: debug : remoteIO:10507 : All done with our call 1 (nil) 0xb4c740
22:22:08.223: 27276: debug : doRemoteOpen:922 : Adding Handler for remote events
22:22:08.223: 27276: debug : virEventAddHandleImpl:103 : Add handle fd=5 events=1 cb=0x309baaf190 opaque=0xb49090
22:22:08.223: 27276: debug : virEventInterruptLocked:668 : Skip interrupt, 0 0
22:22:08.223: 27276: debug : doRemoteOpen:932 : Adding Timeout for remote event queue flushing
22:22:08.223: 27276: debug : virEventAddTimeoutImpl:199 : Adding timer 1 with -1 ms freq
22:22:08.223: 27276: debug : virEventAddTimeoutImpl:207 : Used 0 timeout slots, adding at least 10 more
22:22:08.224: 27276: debug : virEventInterruptLocked:668 : Skip interrupt, 0 0
22:22:08.224: 27276: debug : do_open:1311 : driver 2 remote returned SUCCESS
22:22:08.224: 27276: debug : do_open:1331 : network driver 0 Test returned DECLINED
22:22:08.224: 27276: debug : do_open:1331 : network driver 1 ESX returned DECLINED
22:22:08.224: 27276: debug : do_open:1331 : network driver 2 remote returned SUCCESS
22:22:08.224: 27276: debug : do_open:1350 : interface driver 0 Test returned DECLINED
22:22:08.224: 27276: debug : do_open:1350 : interface driver 1 ESX returned DECLINED
22:22:08.224: 27276: debug : do_open:1350 : interface driver 2 remote returned SUCCESS
22:22:08.224: 27276: debug : do_open:1370 : storage driver 0 Test returned DECLINED
22:22:08.224: 27276: debug : do_open:1370 : storage driver 1 ESX returned DECLINED
22:22:08.224: 27276: debug : do_open:1370 : storage driver 2 remote returned SUCCESS
22:22:08.224: 27276: debug : do_open:1390 : node driver 0 Test returned DECLINED
22:22:08.224: 27276: debug : do_open:1390 : node driver 1 ESX returned DECLINED
22:22:08.224: 27276: debug : do_open:1390 : node driver 2 remote returned SUCCESS
22:22:08.224: 27276: debug : do_open:1417 : secret driver 0 Test returned DECLINED
22:22:08.224: 27276: debug : do_open:1417 : secret driver 1 ESX returned DECLINED
22:22:08.224: 27276: debug : do_open:1417 : secret driver 2 remote returned SUCCESS
22:22:08.224: 27276: debug : do_open:1437 : nwfilter driver 0 Test returned DECLINED
22:22:08.224: 27276: debug : do_open:1437 : nwfilter driver 1 ESX returned DECLINED
22:22:08.224: 27276: debug : do_open:1437 : nwfilter driver 2 remote returned SUCCESS
22:22:08.224: 27276: debug : virDomainLookupByName:2219 : conn=0xb49090, name=vm1
22:22:08.224: 27276: debug : remoteIO:10407 : Do proc=23 serial=2 length=36 wait=(nil)
22:22:08.224: 27276: debug : remoteIO:10479 : We have the buck 23 0xb4ca70 0xb4ca70
22:22:08.224: 27276: debug : virEventUpdateHandleImpl:136 : Update handle w=2 e=0
22:22:08.224: 27276: debug : virEventInterruptLocked:668 : Skip interrupt, 0 0
22:22:08.226: 27276: debug : remoteIODecodeMessageLength:9803 : Got length, now need 84 total (80 more)
22:22:08.226: 27276: debug : remoteIOEventLoop:10333 : Giving up the buck 23 0xb4ca70 (nil)
22:22:08.226: 27276: debug : virEventUpdateHandleImpl:136 : Update handle w=2 e=1
22:22:08.226: 27276: debug : virEventInterruptLocked:668 : Skip interrupt, 0 0
22:22:08.226: 27276: debug : remoteIO:10507 : All done with our call 23 (nil) 0xb4ca70
22:22:08.227: 27276: debug : virGetDomain:381 : New hash entry 0xb4c540
22:22:08.227: 27276: debug : virDomainGetID:2874 : dom=0xb4c540, (VM: name=vm1, uuid=398d9b47-7223-b6af-8d54-314f5b13bda6),
22:22:08.227: 27276: debug : virDomainCreate:5130 : dom=0xb4c540, (VM: name=vm1, uuid=398d9b47-7223-b6af-8d54-314f5b13bda6),
22:22:08.227: 27276: debug : remoteIO:10407 : Do proc=9 serial=3 length=56 wait=(nil)
22:22:08.227: 27276: debug : remoteIO:10479 : We have the buck 9 0xb4cd00 0xb4cd00
22:22:08.227: 27276: debug : virEventUpdateHandleImpl:136 : Update handle w=2 e=0
22:22:08.227: 27276: debug : virEventInterruptLocked:668 : Skip interrupt, 0 0
22:22:08.244: 27276: debug : remoteIODecodeMessageLength:9803 : Got length, now need 92 total (88 more)
22:22:08.244: 27276: debug : remoteIOEventLoop:10333 : Giving up the buck 9 0xb4cd00 (nil)
22:22:08.244: 27276: debug : virEventUpdateHandleImpl:136 : Update handle w=2 e=1
22:22:08.244: 27276: debug : virEventInterruptLocked:668 : Skip interrupt, 0 0
22:22:08.244: 27276: debug : remoteIO:10507 : All done with our call 9 (nil) 0xb4cd00
22:22:08.244: 27276: debug : virDomainGetName:2779 : domain=0xb4c540
error: Failed to start domain vm1
22:22:08.244: 27276: debug : virDomainFree:2307 : dom=0xb4c540, (VM: name=vm1, uuid=398d9b47-7223-b6af-8d54-314f5b13bda6),
22:22:08.244: 27276: debug : virUnrefDomain:462 : unref domain 0xb4c540 vm1 1
22:22:08.244: 27276: debug : virReleaseDomain:415 : release domain 0xb4c540 vm1 398d9b47-7223-b6af-8d54-314f5b13bda6
22:22:08.244: 27276: debug : virReleaseDomain:432 : unref connection 0xb49090 2
error: Unknown failure

22:22:08.244: 27276: debug : virConnectClose:1586 : conn=0xb49090
22:22:08.244: 27276: debug : virUnrefConnect:317 : unref connection 0xb49090 1
22:22:08.244: 27276: debug : virReleaseConnect:249 : release connection 0xb49090
22:22:08.244: 27276: debug : virEventRemoveTimeoutImpl:270 : Remove timer 1
22:22:08.244: 27276: debug : virEventInterruptLocked:668 : Skip interrupt, 0 0
22:22:08.245: 27276: debug : virEventRemoveHandleImpl:163 : Remove handle w=2
22:22:08.245: 27276: debug : virEventRemoveHandleImpl:176 : mark delete 1 5
22:22:08.245: 27276: debug : virEventInterruptLocked:668 : Skip interrupt, 0 0
22:22:08.245: 27276: debug : remoteIO:10407 : Do proc=2 serial=4 length=28 wait=(nil)
22:22:08.245: 27276: debug : remoteIO:10479 : We have the buck 2 0xb4ca70 0xb4ca70
22:22:08.248: 27276: debug : remoteIODecodeMessageLength:9803 : Got length, now need 56 total (52 more)
22:22:08.248: 27276: debug : remoteIOEventLoop:10333 : Giving up the buck 2 0xb4ca70 (nil)
22:22:08.248: 27276: debug : remoteIO:10507 : All done with our call 2 (nil) 0xb4ca70

Comment 4 gregrwm 2011-09-15 03:47:32 UTC
edit /etc/libvirt/libvirtd.conf:
log_level = 1

#  restart libvirtd
#  virsh --connect lxc:/// start vm1

/var/log/messages:
 Sep 14 22:38:46 okra libvirtd: 22:38:46.579: 23714: warning : qemudDispatchSignalEvent:403 : Shutting down on signal 15
 Sep 14 22:38:46 okra libvirtd: 22:38:46.735: 27573: info : libvirt version: 0.8.7, package: 18.el6_1.1 (Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>, 2011-08-08-
 Sep 14 22:38:46 okra libvirtd: Could not find keytab file: /etc/libvirt/krb5.tab: No such file or directory
 Sep 14 22:38:46 okra libvirtd: 22:38:46.765: 27573: info : networkReloadIptablesRules:1382 : Reloading iptables rules
 Sep 14 22:38:47 okra libvirtd: 22:38:47.215: 27573: warning : qemudStartup:1737 : Unable to create cgroup for driver: No such device or address
 Sep 14 22:38:47 okra libvirtd: 22:38:47.216: 27573: info : qemudLoadDriverConfig:312 : Configured cgroup controller 'cpu'
 Sep 14 22:38:47 okra libvirtd: 22:38:47.216: 27573: info : qemudLoadDriverConfig:312 : Configured cgroup controller 'memory'
 Sep 14 22:38:47 okra libvirtd: 22:38:47.216: 27573: info : qemudLoadDriverConfig:312 : Configured cgroup controller 'devices'
 Sep 14 22:38:47 okra libvirtd: 22:38:47.216: 27573: info : qemudLoadDriverConfig:312 : Configured cgroup controller 'blkio'
 Sep 14 22:38:47 okra libvirtd: 22:38:47.216: 27573: info : qemudSecurityInit:1424 : No security driver available
 Sep 14 22:38:47 okra libvirtd: 22:38:47.222: 27573: info : virDomainLoadAllConfigs:8297 : Scanning for configs in /var/run/libvirt/qemu
 Sep 14 22:38:47 okra libvirtd: 22:38:47.231: 27573: info : virDomainLoadAllConfigs:8297 : Scanning for configs in /etc/libvirt/qemu
 Sep 14 22:38:47 okra kernel: lo: Disabled Privacy Extensions
 Sep 14 22:38:47 okra libvirtd: 22:38:47.296: 27573: warning : lxcStartup:2128 : Unable to create cgroup for driver: No such device or address
 Sep 14 22:38:47 okra libvirtd: 22:38:47.296: 27573: info : virDomainLoadAllConfigs:8297 : Scanning for configs in /etc/libvirt/lxc
 Sep 14 22:38:47 okra libvirtd: 22:38:47.296: 27573: info : virDomainLoadAllConfigs:8319 : Loading config file 'vm1.xml'
 Sep 14 22:38:47 okra libvirtd: 22:38:47.297: 27573: info : virDomainLoadAllConfigs:8319 : Loading config file 'mycontainer.xml'
 Sep 14 22:38:47 okra libvirtd: 22:38:47.297: 27573: info : virDomainLoadAllConfigs:8319 : Loading config file 'drvlxcexample1.xml'
 Sep 14 22:38:47 okra libvirtd: 22:38:47.298: 27573: error : lxcMonitorClient:1170 : Failed to connect to client socket: No such file or directory
 Sep 14 22:38:47 okra libvirtd: 22:38:47.298: 27573: error : lxcMonitorClient:1170 : Failed to connect to client socket: No such file or directory
 Sep 14 22:38:47 okra libvirtd: 22:38:47.298: 27573: error : lxcMonitorClient:1170 : Failed to connect to client socket: No such file or directory
 Sep 14 22:39:06 okra libvirtd: 22:39:06.311: 27575: info : qemudDispatchServer:1433 : Turn off polkit auth for privileged client pid 27624 from 127.0.0.1;0

Comment 5 Osier Yang 2011-09-15 09:40:08 UTC
The key error is "lxcMonitorClient:1170 : Failed to connect to client socket: No such file or directory", but I can't reproduce it, and the unix socket for lxc guest montior is corrected automatically, have no idea how you could encount it. :-)

Comment 6 gregrwm 2011-09-15 18:26:53 UTC
to reproduce, just prefix these steps in my original description:
-1.  install rhel6.1
 0.  yum upgrade

Comment 8 Dave Allan 2011-11-23 03:10:23 UTC
As LXC is still tech preview, I am closing as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.