This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 738523 - bind refuses to start in latest update.
bind refuses to start in latest update.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-15 01:12 EDT by Dave Jones
Modified: 2015-01-04 17:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-02 06:30:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2011-09-15 01:12:13 EDT
after updating to 9.8.1-2, bind no longer starts up.
In the logs I see this ..

Sep 15 00:43:43 firewall named[13569]: isc_stdio_open 'data/named.run' failed: file not found
Sep 15 00:43:43 firewall named[13569]: configuring logging: file not found
Sep 15 00:43:43 firewall named[13569]: loading configuration: file not found
Sep 15 00:43:43 firewall named[13569]: exiting (due to fatal error)

reverting to an older version everything starts up fine.
Comment 1 Adam Tkac 2011-09-15 03:58:27 EDT
This is weird, I'm not sure how can this happen. Do you use chroot? Can you please post me perms of the /var/named, /var/named/data and /var/named/data/named.run directories/files (ls -lZ)? Thank you in advance.
Comment 2 Dave Jones 2011-09-15 15:18:02 EDT
bind-chroot is installed.
Stuff looks to be appearing in the chroot correctly.


# ll -Z /var/
drwxr-x---. root named system_u:object_r:named_zone_t:s0 named/


# ll -Z /var/named/
drwxr-x---. root  named system_u:object_r:named_conf_t:s0 chroot/
drwxrwx---. named named system_u:object_r:named_cache_t:s0 data/
lrwxrwxrwx. root  root  unconfined_u:object_r:named_zone_t:s0 db.192.168.42 -> /var/named/chroot/var/named/db.192.168.42
lrwxrwxrwx. root  root  unconfined_u:object_r:named_zone_t:s0 db.kernelslacker.org -> /var/named/chroot/var/named/db.kernelslacker.org
drwxrwx---. named named system_u:object_r:named_cache_t:s0 dynamic/
lrwxrwxrwx. root  root  unconfined_u:object_r:named_zone_t:s0 localdomain.zone -> /var/named/chroot/var/named/localdomain.zone
lrwxrwxrwx. root  root  unconfined_u:object_r:named_zone_t:s0 localhost.zone -> /var/named/chroot/var/named/localhost.zone
lrwxrwxrwx. root  root  unconfined_u:object_r:named_zone_t:s0 named.broadcast -> /var/named/chroot/var/named/named.broadcast
-rw-r-----. root  named system_u:object_r:named_conf_t:s0 named.ca
lrwxrwxrwx. root  root  unconfined_u:object_r:named_zone_t:s0 named.ca.rpmsave -> /var/named/chroot/var/named/named.ca
-rw-r-----. root  named system_u:object_r:named_zone_t:s0 named.empty
lrwxrwxrwx. root  root  unconfined_u:object_r:named_zone_t:s0 named.empty.rpmsave -> /var/named/chroot/var/named/named.empty
lrwxrwxrwx. root  root  unconfined_u:object_r:named_zone_t:s0 named.ip6.local -> /var/named/chroot/var/named/named.ip6.local
lrwxrwxrwx. root  root  unconfined_u:object_r:named_zone_t:s0 named.local -> /var/named/chroot/var/named/named.local
-rw-r-----. root  named system_u:object_r:named_zone_t:s0 named.localhost
lrwxrwxrwx. root  root  unconfined_u:object_r:named_zone_t:s0 named.localhost.rpmsave -> /var/named/chroot/var/named/named.localhost
-rw-r-----. root  named system_u:object_r:named_zone_t:s0 named.loopback
lrwxrwxrwx. root  root  unconfined_u:object_r:named_zone_t:s0 named.loopback.rpmsave -> /var/named/chroot/var/named/named.loopback
lrwxrwxrwx. root  root  unconfined_u:object_r:named_zone_t:s0 named.zero -> /var/named/chroot/var/named/named.zero
drwxrwx---. named named system_u:object_r:named_cache_t:s0 slaves/


/var/named/data/ is empty.


(also setenforce 0 was tried, made no difference, so not selinux related)
Comment 3 Dave Jones 2011-09-26 19:34:52 EDT
Anything else I can provide to diagnose this ?
Comment 4 Adam Tkac 2011-10-06 07:14:51 EDT
Can you please attach (or send me) your named.conf? I'm still unable to reproduce this issue... Also please run `rpm -qV bind` and `rpm -qV bind-chroot` to ensure your installation is correct. Thanks in advance!
Comment 5 Dave Jones 2011-10-06 11:08:15 EDT
sent in email.
Comment 6 JesUs Lima 2011-12-01 18:46:24 EST
The solution for me was to create the directory under the chroot path:

cd /var/named
mkdir chroot/var/named/data
chown named:named  chroot/var/named/data

them verify in /var/log/messages the selinux alert and follow instructions to adapt selinux to this new directory under named control.
Comment 7 Adam Tkac 2011-12-02 06:30:13 EST
(In reply to comment #6)
> The solution for me was to create the directory under the chroot path:
> 
> cd /var/named
> mkdir chroot/var/named/data
> chown named:named  chroot/var/named/data
> 
> them verify in /var/log/messages the selinux alert and follow instructions to
> adapt selinux to this new directory under named control.

Yes, this was also the solution for Dave Jones but I forgot to update this ticket, thanks for your post. Closing.

Note You need to log in before you can comment on or make changes to this bug.