Bug 738534 - virt-sanlock-cleanup command doesn't work
Summary: virt-sanlock-cleanup command doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 6.2
Assignee: Daniel Berrangé
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-15 06:11 UTC by Alex Jia
Modified: 2011-12-06 11:29 UTC (History)
7 users (show)

Fixed In Version: libvirt-0.9.4-12.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:29:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Alex Jia 2011-09-15 06:11:07 UTC
Description of problem:
virt-sanlock-cleanup command raises 'command not found' error.

Version-Release number of selected component (if applicable):
# rpm -q libvirt
libvirt-0.9.4-11.el6.x86_64

# rpm -q libvirt-lock-sanlock
libvirt-lock-sanlock-0.9.4-11.el6.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. enable sanlock in qemu.conf
# tail -1 /etc/libvirt/qemu.conf
lock_manager = "sanlock"
2. enable host_id, auto_disk_leases and disk_lease_dir in qemu-sanlock.conf
# tail -3 /etc/libvirt/qemu-sanlock.conf
host_id = 1
auto_disk_leases = 1
disk_lease_dir = "/var/lib/libvirt/sanlock"
3. service libvirtd restart

4. you should see '__LIBVIRT__DISKS__' is generated:
# ll /var/lib/libvirt/sanlock/
total 1028
-rw-------. 1 root root 1048576 Sep 15 13:54 __LIBVIRT__DISKS__

5. run virt-sanlock-cleanup



In addition, sanlock daemon is running:
# service sanlock status
sanlock (pid 25417) is running...


Actual results:
# virt-sanlock-cleanup
/usr/sbin/virt-sanlock-cleanup: line 32: __LIBVIRT__DISKS__: command not found

Expected results:
fix it.

Additional info:
virt-sanlock-cleanup command doesn't work due to missing test command in /usr/sbin/virt-sanlock-cleanup.

Comment 1 Alex Jia 2011-09-15 06:13:24 UTC
Patch for upstream:
http://www.redhat.com/archives/libvir-list/2011-September/msg00567.html

Alex

Comment 5 Alex Jia 2011-09-21 03:31:24 UTC
virt-sanlock-cleanup works well on rhel6.2 beta with libvirt-lock-sanlock-0.9.4-12.el6.x86_64 now, so move the bug to VERIFIED status.

# virt-sanlock-cleanup
Cleanup: __LIBVIRT__DISKS__:9ba8f0215a51a6dc0aa077c427b749c8:/var/lib/libvirt/sanlock/9ba8f0215a51a6dc0aa077c427b749c8:0 PASS
Cleanup: __LIBVIRT__DISKS__:a2976d05f2d68e58e4af04183d076b4e:/var/lib/libvirt/sanlock/a2976d05f2d68e58e4af04183d076b4e:0 PASS


Alex

Comment 6 errata-xmlrpc 2011-12-06 11:29:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.