Bug 73854 - Application doesn't start / crashes when appending to start it
Application doesn't start / crashes when appending to start it
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-mouse (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-12 06:04 EDT by Benjamin Sommerfeld
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-01 20:11:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Sommerfeld 2002-09-12 06:04:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
It just doesn't work at all. See the console-output when i try to start the
application:

redhat-config-mouse
Traceback (most recent call last):
  File "/usr/share/redhat-config-mouse/redhat-config-mouse.py", line 13, in ?
    app.stand_alone()
  File "/usr/share/redhat-config-mouse/mouse_gui.py", line 306, in stand_alone
    self.setupScreen()
  File "/usr/share/redhat-config-mouse/mouse_gui.py", line 53, in setupScreen
    self.mouse = mouse.Mouse()
  File "/usr/lib/python2.2/site-packages/rhpl/mouse.py", line 120, in __init__
    self.probe()
  File "/usr/lib/python2.2/site-packages/rhpl/mouse.py", line 191, in probe
    self.set("No mouse")
  File "/usr/lib/python2.2/site-packages/rhpl/mouse.py", line 229, in set
    (gpm, x11, dev, em, shortname) = self.mice[mouse]
KeyError: No mouse



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.become root (su)
2.try to start redhat-config-mouse
3. crash!
	

Actual Results:  the application crashed

Expected Results:  the application should have started

Additional info:
Comment 1 Hypercube 2002-09-17 01:57:09 EDT
I believe that this is the simple fix:

--- /usr/lib/python2.2/site-packages/rhpl/mouse.py.old  2002-09-16
22:46:39.000000000 -0700
+++ /usr/lib/python2.2/site-packages/rhpl/mouse.py      2002-09-16
22:48:36.000000000 -0700
@@ -188,7 +188,7 @@
            self.wasProbed = 1
             return 1
         else:
-            self.set("No mouse")
+            self.set("No - mouse")
            self.wasProbed = 0
             return 0
Comment 2 Hypercube 2002-10-01 20:11:02 EDT
Looks like this has been fixed in 8.0 final. (rhpl-0.51-1)
Comment 3 Brent Fox 2002-10-02 11:19:13 EDT
My guess is that katzj fixed it in rhpl.

Note You need to log in before you can comment on or make changes to this bug.