Bug 738570 - Ekiga missing codecs
Summary: Ekiga missing codecs
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ekiga (Show other bugs)
(Show other bugs)
Version: 16
Hardware: All Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE-Legal
TreeView+ depends on / blocked
 
Reported: 2011-09-15 08:35 UTC by Steve Hill
Modified: 2017-06-28 16:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-22 21:33:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Hill 2011-09-15 08:35:36 UTC
Description of problem:
The Ekiga website states that Ekiga 3.3.2 includes H.263 and H.264 video codecs:
http://ekiga.org/news/2011-08-26/ekiga-3.3.2-unstable-available
However, the Ekiga 3.3.2 that ships in the Fedora 16 development repo only includes Theora and H.261.

I'm not sure what the patent status is with H.263, but I presume it is safe to distribute since Empathy supports it.

Version-Release number of selected component (if applicable):
ekiga-3.3.2-3.fc16.x86_64

Comment 1 Peter Robinson 2011-09-15 09:32:06 UTC
We certainly can't ship H.264 due to patent restrictions, its my understanding that H.263 is restricted too as it uses some MPEG but I'm not sure if its a sub component and whether it can easily be removed from ekiga. Adding Legal to confirm.

http://fedoraproject.org/wiki/Forbidden_items

The actual codec code is standalone so doesn't depend on third party stuff not in Fedora
http://opalvoip.svn.sourceforge.net/viewvc/opalvoip/opal/trunk/plugins/video/H.263-1998/

Some things I've found are:
http://scratchpad.wikia.com/wiki/Notes_on_H.263_Patent_Status
http://www.nine-9s.com/h-263-codec-software.htm

Comment 2 Steve Hill 2011-09-15 10:13:33 UTC
If H.263 is restricted, why do we have H.263 support in Empathy?  (Indeed, Empathy doesn't appear to support anything but H.263 for SIP calls, so without that it'd be pretty useless).

Maybe there is some chance of splitting out these codecs into separate RPMs that could be hosted on rpmfusion for those of us who live in freer parts of the world that aren't governed with insane patent laws?

I've so far been unable to convince Opal to build with H.263.  From my reading on the subject it depends on ffmpeg (the build instructions on the Ekiga site conveniently tell me I need the svn version of ffmpeg rather than telling me specifically which revision I need.  Since ffmpeg has been hosted on git rather than svn for ages I can only assume these instructions are very out of date so presumably the packaged ffmpeg on rpmfusion should work(?)).  Opal's ./configure just tells me it isn't building with H.263 support, but I've yet to figure out why.

The Ekiga wiki seems to be dead at the moment, but the google cache of it is: http://webcache.googleusercontent.com/search?q=cache:3DM4yjghq34J:wiki.ekiga.org/index.php/Compiling_Ekiga+ekiga+opal&cd=1&hl=en&ct=clnk&gl=uk&client=firefox-a

Comment 3 Tom "spot" Callaway 2012-02-22 21:33:46 UTC
Reviving this old bug:

Empathy is using Gstreamer to provide the SIP audio/video codec support. Fedora's Gstreamer does not have H.263 support, so Empathy in Fedora doesn't support it either.

Ekiga uses opal. Opal, as packaged in Fedora, does not enable H.263.

So, I'm closing out this ticket, as the H.263 disablement in Fedora is intentional, and I cannot comment on what third parties can or cannot do to provide addon packages with functionality not permissible in Fedora.


Note You need to log in before you can comment on or make changes to this bug.