Bug 738593 - Rhsm shows uninstalled product when --installed param is used
Rhsm shows uninstalled product when --installed param is used
Status: CLOSED DUPLICATE of bug 736424
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-09-15 06:13 EDT by Lukas Zapletal
Modified: 2015-05-14 11:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-22 13:51:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2011-09-15 06:13:11 EDT
Description of problem:

I registered a client against Katello, I tried to show all installed products, but I get a product with "Not Installed" status.

sudo subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Awesome OS Workstation Bits
Status:             	Not Installed            
Expires:            	06/13/2012               
SerialNumber:       	2055993395520614221      
ContractNumber:     	8                        
AccountNumber:      	12331131231             

Quite confusing. If this is NOTABUG please close. But maybe it is.

$ rpm -q candlepin pulp subscription-manager python-rhsm
candlepin-0.4.10-1.fc15.noarch
pulp-0.0.223-4.fc15.noarch
subscription-manager-0.96.9-1.fc15.i686
python-rhsm-0.96.12-1.fc15.noarch
Comment 1 John Sefler 2011-09-15 10:23:52 EDT
This behavior is working as designed (The "Not Installed" status indicates that you are subscribed to an entitlement, Awesome OS Workstation Bits, for which you do not have a corresponding product cert installed).  However the design is about to change...

I suggest returning this bug as a dup of bug 736424
Comment 2 Bryan Kearney 2011-09-22 13:51:19 EDT

*** This bug has been marked as a duplicate of bug 736424 ***

Note You need to log in before you can comment on or make changes to this bug.