Bug 738602 - Can't save traceback to custom-named file
Can't save traceback to custom-named file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Denys Vlasenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ABRTF17
  Show dependency treegraph
 
Reported: 2011-09-15 06:45 EDT by Kamil Páral
Modified: 2011-11-21 17:51 EST (History)
8 users (show)

See Also:
Fixed In Version: abrt-2.0.6-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-21 17:51:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
abrt bug (53.62 KB, image/png)
2011-09-15 06:45 EDT, Kamil Páral
no flags Details
save to tmp (27.24 KB, image/png)
2011-09-15 09:16 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2011-09-15 06:45:52 EDT
Created attachment 523341 [details]
abrt bug

Description of problem:
I hit a traceback in anaconda. In abrt I selected Report uploader, put file:///report into URL (or file:///tmp/soubor for the second time), hit OK, abrt failed (see screenshot).

Version-Release number of selected component (if applicable):
Fedora 16 Beta TC2
rpm package not installed (no kidding), I can't find out exact versions

Additional info:
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_save_traceback_to_disk
Comment 1 Kamil Páral 2011-09-15 06:48:41 EDT
So, we have this in the list of QA's test cases marked for Alpha milestone, but I can't find relevant release criteria. Proposing as Final blocker.
Comment 2 Jiri Moskovcak 2011-09-15 07:02:38 EDT
This is not a blocker. Saving to the local disk is not a critical feature, you can still copy /tmp/anaconda-tb-* and send it manually. And btw, the example is wrong, the directory has to exist, uploader is just trying to upload the tarball to the given URL.
Comment 3 Kamil Páral 2011-09-15 07:14:50 EDT
With further attempts I found out that saving to file:///tmp works. It clearly expects a (existing) directory, not directory/file. Removing blocker proposal, it kind of works, just not optimally.

Renaming this bug accordingly. Please support file:///directory/file syntax or inform the user that he has to use a different syntax.
Comment 4 Kamil Páral 2011-09-15 08:25:09 EDT
I have found one more problem. When you save to /, it creates a tgz file. When you save to /tmp, it creates a directory full of files. Weird.
Comment 5 Jiri Moskovcak 2011-09-15 08:32:17 EDT
(In reply to comment #4)
> I have found one more problem. When you save to /, it creates a tgz file. When
> you save to /tmp, it creates a directory full of files. Weird.

The dir in /tmp is the original directory created when the bug is found, then it's gzipped and (because you told it so) uploaded to /tmp. So there should be both - dir and tarball. Try to check the timestamps.
Comment 6 Kamil Páral 2011-09-15 09:16:43 EDT
Created attachment 523377 [details]
save to tmp

Nope, gzip is not in /tmp. It seems that it tries to move the file to itself.
Comment 7 Denys Vlasenko 2011-10-25 06:50:09 EDT
Fixed in git:

commit 3ef5d54dfabba7b69352ec85879d0da9daab74ba
Author: Denys Vlasenko <dvlasenk@redhat.com>
Date:   Tue Oct 25 02:17:57 2011 +0200

    reporter-upload: add possibility to specify _file_ part in url

    Work around a problem where we copy file on itself in /tmp
    if url is file:///tmp/.

    Add explanation to --help text, manpage, and add
    examples to GUI config window.
Comment 8 Fedora Update System 2011-11-05 14:58:24 EDT
abrt-2.0.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/abrt-2.0.6-1.fc16
Comment 9 Fedora Update System 2011-11-06 18:55:44 EST
Package abrt-2.0.6-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.6-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15513
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-11-21 17:51:40 EST
abrt-2.0.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.