Bug 738635 - scp upload ends with 'Error in the SSH layer'
scp upload ends with 'Error in the SSH layer'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
16
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ABRTF18
  Show dependency treegraph
 
Reported: 2011-09-15 08:49 EDT by Kamil Páral
Modified: 2015-02-01 17:54 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 20:12:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
abrt bug (48.11 KB, image/png)
2011-09-15 08:49 EDT, Kamil Páral
no flags Details
current unfriendly UI (7.70 KB, image/png)
2012-08-10 06:40 EDT, Jiri Moskovcak
no flags Details

  None (edit)
Description Kamil Páral 2011-09-15 08:49:08 EDT
Created attachment 523372 [details]
abrt bug

Description of problem:
I used report uploader to report anaconda traceback. I wanted to save the traceback to remote system over scp. I received a message 'Error in the SSH layer' every time. When using scp manually the transfer worked ok.

Version-Release number of selected component (if applicable):
Fedora 16 Beta TC2
anaconda 16.17

Additional info:
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_save_traceback_to_remote_system
Comment 1 Kamil Páral 2011-09-15 08:57:51 EDT
Proposing as F16 NTH, it can't be fixed afterwards.
Comment 2 Kamil Dudka 2011-09-15 09:00:53 EDT
(In reply to comment #0)
> Created attachment 523372 [details]
> abrt bug

The URL is wrong, see the following FAQ:

http://curl.haxx.se/docs/faq.html#How_to_SFTP_from_my_user_s_home
Comment 3 Kamil Páral 2011-09-15 09:21:14 EDT
There is no documentation about supported syntax in the UI. So what is the correct syntax I can use _inside ABRT_ for scp and ftp?
Comment 4 Jiri Moskovcak 2011-09-15 09:27:44 EDT
The url from ui is passed directly to curl, so it's the same syntax as curl uses. URL is the directory where abrt should upload the file.
Comment 5 Kamil Páral 2011-09-15 09:47:10 EDT
OK, I found the scp syntax:

scp://login:password@host/path 

This one works.

I'll leave this bug open until we figure out the ftp syntax (including path segment), because I need to document it in our test case [1]. If you know it (<poke>you should, you are the developers</poke>), please state it here.

Removing blocker, functionality works, it's just utterly unfriendly.

[1] https://fedoraproject.org/wiki/QA:Testcase_Anaconda_save_traceback_to_remote_system
Comment 6 Kamil Dudka 2011-09-16 15:30:25 EDT
(In reply to comment #5)
> OK, I found the scp syntax:
> 
> scp://login:password@host/path
> 
> This one works.
> 
> I'll leave this bug open until we figure out the ftp syntax (including path
> segment), because I need to document it in our test case [1]. If you know it
> (<poke>you should, you are the developers</poke>), please state it here.

Sounds weird to me.  Did you try to replace 'scp' by 'ftp' in the scheme above?  If you need a more detailed howto, you can have a look at RFC 1738...
Comment 7 Kamil Páral 2011-09-19 05:25:08 EDT
I haven't tested FTP yet. I hope that you, as the program authors, are able to tell me the supported syntax, so that I can instruct testers to regularly test it, instead of finding the syntax using the trial-and-error approach.
Comment 8 Kamil Dudka 2011-09-19 05:53:22 EDT
The syntax is RFC 1738.  Whoever can use a web browser knows how a URL looks like.  The only extension in libcurl is the use of '~' for specifying user's home directory as I already mentioned in comment #2 (RFC 1738 says nothing about SCP and SFTP, but it does describe the URL syntax for FTP).
Comment 9 Jiri Moskovcak 2011-09-19 09:52:50 EDT
ok guys, we have 2 proposals how to fix this:

1. add a example text into the dialog:

SCP: scp://name:password@hostname/directory
FTP ftp://name:password@hostname/directory

2. use different UI:
http://jmoskovc.fedorapeople.org/report_uploader_ui.png

Ideas?
Comment 10 Kamil Dudka 2011-09-19 10:10:58 EDT
(In reply to comment #9)
> 1. add a example text into the dialog:
> 
> SCP: scp://name:password@hostname/directory
> FTP ftp://name:password@hostname/directory

In the SCP example, I would either use the '~':

scp://name:password@hostname/~/directory

... or an apparent absolute path:

scp://name:password@hostname/home/bob/directory

Otherwise, most users would end up in non-existing directories since sending files somewhere to the home directory is a common use-case.

> 2. use different UI:
> http://jmoskovc.fedorapeople.org/report_uploader_ui.png

That would introduce an unnecessary limitation.  libcurl supports ~20 protocols (although not all of them are suitable for sending ABRT reports).
Comment 11 Kamil Páral 2011-09-19 10:22:40 EDT
UI is more user friendly. Just please add some example inside (at least a tooltip) how the address should look like (I guess "host" or "host/path").


> That would introduce an unnecessary limitation.  libcurl supports ~20 protocols
> (although not all of them are suitable for sending ABRT reports).

Well with current UI I would be very surprised if anyway except ABRT developers knew how to use it.

With good UI docs even the one-line text field could be usable.
Comment 12 Kamil Páral 2011-09-19 10:23:54 EDT
> Well with current UI I would be very surprised if anyway except ABRT
                                                    ^^anyone
Comment 13 Jiri Moskovcak 2012-08-10 06:40:09 EDT
Created attachment 603465 [details]
current unfriendly UI

The uploader config dialog looks awfull with gtk3, I still propose using the other UI - even tho it's limitating, but c'mon who will use something else than ftp, scp, file ?? I really don't like this over generic approach which only leads to unusable UIs.
Comment 14 Denys Vlasenko 2012-08-17 11:31:41 EDT
I think after this commit it looks significantly better:

commit c3aaa2ae358657501a23dd1fe29535c0ffcc2521
Author: Denys Vlasenko <vda.linux@googlemail.com>
Date:   Fri Aug 17 17:29:13 2012 +0200

    event_config_dialog: make it resizable; tweak Uploader hint

    Uploader config had its hint text horribly wrapped.
    Now the window looks like this:

    URL: [..........................................]
         Examples:
         ftp://[user[:pass]@]host/dir/[file.tar.gz]
         scp://[user[:pass]@]host/dir/[file.tar.gz]
         file:///dir/[file.tar.gz]
Comment 15 Fedora Update System 2012-12-20 03:53:04 EST
abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18
Comment 16 Fedora Update System 2012-12-20 04:44:11 EST
abrt-2.0.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc17
Comment 17 Fedora Update System 2012-12-20 20:27:08 EST
Package abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.20-1.fc18 btparser-0.24-1.fc18 libreport-2.0.20-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20725/abrt-2.0.20-1.fc18,btparser-0.24-1.fc18,libreport-2.0.20-1.fc18
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2013-01-11 20:12:34 EST
abrt-2.0.20-1.fc18, btparser-0.24-1.fc18, libreport-2.0.20-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-02-25 21:35:48 EST
abrt-2.0.20-1.fc17, btparser-0.24-1.fc17, libreport-2.0.20-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.