Bug 73870 - Euro symbol and french characters
Euro symbol and french characters
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Eido Inoue
Depends On:
  Show dependency treegraph
Reported: 2002-09-12 12:35 EDT by Olivier de Liocourt
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-07-14 12:29:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Olivier de Liocourt 2002-09-12 12:35:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [fr] (X11; U; Linux 2.4.18-10 i686; Nav)

Description of problem:
Euro and special french characters like a or e not working in console mode. I
changed the kbd package with the console-tools of the 7.3, changing encoding
from UTF to ASCII and changing the font to lat0-sun16, it is working (euro
symbol and french characters).
Another problem in console mode is with altgr button. When Numlock is activated,
altgr gives a 0 (zero) on the screen.
The french keyboard is fr-latin1, I tried  to use english language by default,
using fr-latin1 keyboard, the problem is the same

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
	1. Install+use in french language
2. use keyboard fr-latin1
3. log on a tty1 in root
4. try to use altgr+e (the same on a qwerty kbd)
5. activate Numlock, and type altgr, look at the screen

Actual Results:  altgr+e gives e

Expected Results:  altgt+e gives Euro symbol

Additional info:

contact me on liocourt@redhat.com or on IRC, nick: oli
if you need help
Comment 1 Matt 2003-01-09 08:36:17 EST
I have exactly the same problem.
Changing LANG from fr_FR.UTF-8 to fr_FR.ISO8859-15 or other French variants does
not solve the problem. And changing SYSFONT to lat0-sun16 does not solve the
problem in RH 8.0. 
I have tried RH 8.0 on two different machines with the same result.
Many French people from my Linux User Group told me that they are going back to
RedHat 7.3 because of the very very annoying problem of Alt Gr displaying a
zero. Please, Red Hat, fix it as soon as you can.
Comment 2 Eido Inoue 2003-01-09 16:10:02 EST
does using "loadkeys euro2" enable this? (you have to be using a latin9 font...
but if you need euro, I imagine you're already doing this)
Comment 3 Eido Inoue 2003-01-09 16:37:46 EST
Ignore the previous-- answered my own question. Was this a fresh install or a
upgrade from a previous version? (if so, which)
Comment 4 Olivier de Liocourt 2003-01-10 06:48:45 EST
It is a fresh install. It is the same thing on 8.0.
Comment 5 Matt 2003-01-10 07:28:44 EST
Could it be a kernel bug?
I installed console-tools from RH 7.3 and mingetty from RH 7.3 and I still get a
zero in console mode with Alt-Gr and Numlock ON. So, the bug might be somewhere
else... I will try to install kbd 1.08. 
Comment 6 Olivier de Liocourt 2003-01-10 07:36:13 EST
the problem of the zero with AltGr+NumLOCK ON doesn't exist anymore on the BETA. 
Matt: please do comment here only about the beta. Thanks.
Comment 7 Eido Inoue 2003-07-14 12:29:59 EDT
non-ASCII input into the console won't be supported on UTF-8 based systems (RHL
8+) until the kernel supports it. See the release notes in the next beta for
more info. Of course, input through X will always be supported.

Note You need to log in before you can comment on or make changes to this bug.