Bug 738716 - LiveCD boot failed with selinux=0
LiveCD boot failed with selinux=0
Status: CLOSED DUPLICATE of bug 727068
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-09-15 11:55 EDT by nucleo
Modified: 2011-09-19 04:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-19 04:18:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2011-09-15 11:55:58 EDT
Description of problem:
I added selinux=0 kernel parameter on 16-Beta.RC1 LiveCD but system boot failed.

Version-Release number of selected component (if applicable):
dracut-013-8.fc16

Steps to Reproduce:
1. Start LiveCD, for example this one http://alt.fedoraproject.org/pub/alt/stage/16-Beta.RC1/Live/i686/Fedora-16-Beta-i686-Live-KDE.iso
2. add kernel parameter selinux=0 and boot
  
Actual results:
Boot failed with error message:
Mount failed for selinuxfs on /sys/fs/selinux: No such file or directory.
Comment 1 Tim Flink 2011-09-16 17:08:11 EDT
Is this the same thing as #727068? If so, enforcing=0 does work as a workaround.

I don't think that this is a beta blocker though. It comes close to hitting the final release criterion [1] :

The installed system must run normally if the user chooses to install without SELinux 

Since it doesn't hit any beta release criterion, I'm -1 beta blocker on this. Probably +1 final blocker, though.

[1] https://fedoraproject.org/wiki/Fedora_16_Final_Release_Criteria
Comment 2 nucleo 2011-09-16 17:15:03 EDT
bug 727068 about rawhide and not about F16 LiveCD but looks very similar to this bug.
I set Blocks: to F16Blocker (not F16Beta).
Comment 3 nucleo 2011-09-16 17:46:32 EDT
F16 CD boots with both selinux=0 and enforcing=0 parameters so maybe this is the same bug.
Comment 4 Harald Hoyer 2011-09-19 04:18:59 EDT
dracut in F16 does not setup selinux anymore.

*** This bug has been marked as a duplicate of bug 727068 ***

Note You need to log in before you can comment on or make changes to this bug.