Bug 73873 - anaconda sometimes failed to partition the disk
anaconda sometimes failed to partition the disk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-12 13:52 EDT by hjl
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-12 13:52:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hjl 2002-09-12 13:52:38 EDT
When I do clean install with a different
partition scheme over existing RedHat 7.3
installation, anaconda sometimes failed
to close the old disk fd. As the result,
the new partition table won't be reread
by kernel. I fixed the bug in RedHat 7.1
with

Index: iw/rootpartition_gui.py
===================================================================
RCS file: /work/cvs/redhat/anaconda/iw/rootpartition_gui.py,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -p -r1.1 -r1.2
--- iw/rootpartition_gui.py     10 Jun 2000 03:04:23 -0000      1.1
+++ iw/rootpartition_gui.py     11 Jun 2000 01:31:07 -0000      1.2
@@ -193,6 +193,10 @@ class AutoPartitionWindow(InstallWindow)
                 clearcache = 0
 #            clearcache = not self.todo.fstab.getRunDruid()
            self.todo.fstab.setRunDruid(1)
+           # We have to do it. Otherwise, we may open the hard drives
+           # more than once. It may cause trouble when we revalidate
+           # the hard drives after we change their partition tables.
+           self.druid = None
             self.todo.fstab.setReadonly(0)
             #print "Rescanning partitions 2 - ", clearcache
            self.todo.fstab.rescanPartitions(clearcache)

But this patch no longer applies to 7.3. I believe the bug
is still there.
Comment 1 hjl 2002-09-12 20:36:44 EDT
It happens with kickstart on an IDE HD connected to
a Promise RAID controller.
Comment 2 hjl 2002-09-13 17:31:07 EDT
More info. It doesn't happen with SCSI HD.
After reboot, the installation works fine
since kernel gets the new partion table.
Comment 3 Jeremy Katz 2002-12-11 17:55:04 EST
What makes you think this bug is still there?  Without verification that it's
present in anything newer than 7.1 (and preferably, in GinGin), my inclincation
would be to close current release
Comment 4 hjl 2002-12-12 13:51:53 EST
We no longer use Promise IDE RAID controller.
I suspect it may be a bug in Promise IDE RAID
driver. It only happened when a single HD
was connected to Promise IDE RAID controller.
Comment 5 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.