Bug 738783 - After updating fc14 to fc15 with preupgrade usb 3.0 stopped working
Summary: After updating fc14 to fc15 with preupgrade usb 3.0 stopped working
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: i686
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-15 19:01 UTC by markus.offenau
Modified: 2011-11-29 09:38 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 732783
Environment:
Last Closed: 2011-11-29 09:38:05 UTC


Attachments (Terms of Use)
dmesg (74.73 KB, text/plain)
2011-09-15 19:18 UTC, markus.offenau
no flags Details

Description markus.offenau 2011-09-15 19:01:36 UTC
+++ This bug was initially created as a clone of Bug #732783 +++

Description of problem:
My usb 3.0 ports stopped working after I upgraded from fc14 to fc15 with preupgrade. My usb mouse, my usb keyboard and my usb memory are not working anymore.

When I installed fc14 I had to pass the kernel the parameter xhci.enable=1 and added the file /etc/pm/config.d/xhci in order to get my usb 3.0 working. Now that I've upgraded I removed the kernel parameter and removed the file but the usb 3.0 ports are not working anymore.

The strangest thing is that when I plug my mouse or keyboard and do a "lsusb", none of the appear listed.

Version-Release number of selected component (if applicable):
2.6.40.4-5.fc15.i686.PAE

How reproducible:
Always

Steps to Reproduce:
1.Plug in any usb device on any of the usb 3.0 ports
2.
3.
  
Actual results:
The usb device plugged on the usb 3.0 ports does not work.

Expected results:
The usb device plugged on the usb 3.0 should work.

Additional info:

Comment 1 markus.offenau 2011-09-15 19:18:04 UTC
Created attachment 523432 [details]
dmesg

Comment 2 Don Zickus 2011-09-22 14:00:53 UTC
What happens if you remove all the xhci stuff from your command line.  Originally it was disable because it didn't have power management support (and we thought it would drain laptop batteries). 

That is all fixed with 2.6.40.., so it should the module should just load (assuming you removed any other restriction).

So nothing seems to be working because the module isn't loading.  Oddly it might be because of the xhci.enable=1 you have.  That didn't sit well in your dmesg log.  Not sure why that cause problems.

Cheers,
Don

Comment 3 Chuck Ebbert 2011-09-26 13:57:23 UTC
As Don points out, you did not remove the kernel command-line option.


Note You need to log in before you can comment on or make changes to this bug.