Bug 738801 - WARNING: at drivers/mmc/host/sdhci.c:934 sdhci_send_command+0x37/0x88a [sdhci](): TAINTED ---------W
Summary: WARNING: at drivers/mmc/host/sdhci.c:934 sdhci_send_command+0x37/0x88a [sdhci...
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1d4017dc85466fd2249b688e905...
: 744467 747275 760315 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-15 20:39 UTC by Fabian A. Scherschel
Modified: 2013-04-05 19:44 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-05 19:44:15 UTC


Attachments (Terms of Use)

Description Fabian A. Scherschel 2011-09-15 20:39:33 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        ro root=UUID=d08f3698-bc02-4389-9c6f-3ec878159e10 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=de rhgb quiet
comment:        Inserted an SD card and tried to copy the pictures off
component:      kernel
kernel:         2.6.40.4-5.fc15.x86_64
kernel_tainted: 512
kernel_tainted_long: Taint on warning.
os_release:     Fedora release 15 (Lovelock)
package:        kernel
reason:         WARNING: at drivers/mmc/host/sdhci.c:934 sdhci_send_command+0x37/0x88a [sdhci]()
time:           Thu Sep 15 22:35:15 2011

backtrace:
:WARNING: at drivers/mmc/host/sdhci.c:934 sdhci_send_command+0x37/0x88a [sdhci]()
:Hardware name: 12942PG
:Modules linked in: vfat fat mmc_block usb_storage uas tcp_lp fuse 8021q garp stp llc bnep bluetooth cpufreq_ondemand acpi_cpufreq mperf ip6t_REJECT nf_conntrack_ipv6 nf_conntrack_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device arc4 uvcvideo iwlagn videodev iTCO_wdt snd_pcm media e1000e iTCO_vendor_support snd_timer snd_page_alloc xhci_hcd i2c_i801 v4l2_compat_ioctl32 sparse_keymap microcode thinkpad_acpi mac80211 cfg80211 snd rfkill soundcore joydev ipv6 sdhci_pci sdhci mmc_core wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 0, comm: swapper Not tainted 2.6.40.4-5.fc15.x86_64 #1
:Call Trace:
: <IRQ>  [<ffffffff81054c8e>] warn_slowpath_common+0x83/0x9b
: [<ffffffff81054cc0>] warn_slowpath_null+0x1a/0x1c
: [<ffffffffa00f1dbc>] sdhci_send_command+0x37/0x88a [sdhci]
: [<ffffffff8124b7d7>] ? swiotlb_unmap_sg_attrs+0x3c/0x58
: [<ffffffffa00f1c41>] ? dma_unmap_sg_attrs.constprop.9+0x42/0x49 [sdhci]
: [<ffffffffa00f2803>] sdhci_finish_data+0x1f4/0x212 [sdhci]
: [<ffffffffa00f2f68>] sdhci_irq+0x591/0x664 [sdhci]
: [<ffffffff810adfe4>] handle_irq_event_percpu+0x53/0x1a5
: [<ffffffff810ae16e>] handle_irq_event+0x38/0x56
: [<ffffffff810754cc>] ? sched_clock_cpu+0x42/0xc6
: [<ffffffff810b0256>] handle_fasteoi_irq+0x77/0x9b
: [<ffffffff8100ab6d>] handle_irq+0x88/0x8e
: [<ffffffff8149029d>] do_IRQ+0x4d/0xa5
: [<ffffffff81488493>] common_interrupt+0x13/0x13
: <EOI>  [<ffffffff8100e969>] ? paravirt_read_tsc+0x9/0xd
: [<ffffffff812841b0>] ? intel_idle+0xd8/0x100
: [<ffffffff81284192>] ? intel_idle+0xba/0x100
: [<ffffffff813af949>] cpuidle_idle_call+0xd7/0x168
: [<ffffffff81008307>] cpu_idle+0xa5/0xdf
: [<ffffffff8146741e>] rest_init+0x72/0x74
: [<ffffffff81b66b8b>] start_kernel+0x3ca/0x3d5
: [<ffffffff81b662c4>] x86_64_start_reservations+0xaf/0xb3
: [<ffffffff81b66140>] ? early_idt_handlers+0x140/0x140
: [<ffffffff81b663ca>] x86_64_start_kernel+0x102/0x111

Comment 1 Thomas Jürges 2011-09-16 09:54:00 UTC
Package: kernel
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Copied files from hard drive to sd-card and unmounted the sd-card afterwards.

Comment 2 Chuck Ebbert 2011-09-16 15:30:55 UTC
drivers/mmc/host/sdhci.c:934 sdhci_send_command+0x37/0x88a:
        WARN_ON(host->cmd);

I guess this means it's still busy sending a command?

Comment 3 Thomas Jürges 2011-09-17 21:13:35 UTC
I just remembered that I did everything (mount, copy, umount) through KDE 4 when this happened and it was not the first oops of this kind when I did an umount of an sd-card in that built-in reader.

I rebooted later and did some more copying manually (mount, cp, umount in a shell) which worked fine.  Also the same procedure with a USB card-reader worked fine.

Cheers,
T.

Comment 4 Thomas Jürges 2011-09-17 21:16:04 UTC
I cannot tell if it was still busy because all but the power LED do not work on my laptop (Lenovo T520) due to problems with the graphics card driver(s) - it is this nvidia optimus/intel thing. :-(  Therefore there was no indication of further activity after KDE reported that it would be safe to remove the card.

Cheers,
T.

Comment 5 Chuck Ebbert 2011-11-29 09:35:20 UTC
*** Bug 744467 has been marked as a duplicate of this bug. ***

Comment 6 Josh Boyer 2011-11-29 19:49:01 UTC
*** Bug 747275 has been marked as a duplicate of this bug. ***

Comment 7 Josh Boyer 2011-12-05 20:28:36 UTC
*** Bug 760315 has been marked as a duplicate of this bug. ***

Comment 8 Dan Ziemba 2011-12-20 04:04:28 UTC
I'm getting a very similar error on my macbook pro 8,1 running Fedora 16.  I put a sdcard in the reader, unmounted with disk manager, then ran photorec from gnome-terminal.  When it was almost done the error started happening repeatedly, about once per second until I removed the card.  I put the card back in to copy files to it, it auto-mounted, and I copied one file successfully.  After trying to copy another, the errors started again and the copy didn't happen.  

The card reader:
$ lspci -vvknn | grep SD
02:00.1 SD Host controller [0805]: Broadcom Corporation NetXtreme BCM57765 Memory Card Reader [14e4:16bc] (rev 10) (prog-if 01)


Here's the back trace:

WARNING: at drivers/mmc/host/sdhci.c:777 sdhci_send_command+0x5e9/0x85b [sdhci]()
Hardware name: MacBookPro8,1
Modules linked in: mmc_block usb_storage cdc_acm uas b43 mac80211 cfg80211 bcma ssb tcp_lp ppdev parport_pc lp parport fuse lockd vboxpci vboxnetadp vboxnetflt vboxdrv rfcomm bnep coretemp nf_conntrack_ipv4 nf_conntrack_netbios_ns nf_defrag_ipv4 nf_conntrack_broadcast ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables vfat fat arc4 snd_hda_codec_hdmi snd_hda_codec_cirrus applesmc iTCO_wdt iTCO_vendor_support joydev uvcvideo btusb videodev media v4l2_compat_ioctl32 bcm5974 bluetooth rfkill tg3 snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc microcode i2c_i801 input_polldev apple_bl sunrpc uinput binfmt_misc firewire_ohci firewire_core crc_itu_t sdhci_pci sdhci mmc_core i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: ssb]
Pid: 8149, comm: mmcqd/0 Tainted: G        WC  3.1.2-1.fc16.x86_64 #1
Call Trace:
 [<ffffffff81057a1e>] warn_slowpath_common+0x83/0x9b
 [<ffffffff81057a50>] warn_slowpath_null+0x1a/0x1c
 [<ffffffffa00553b8>] sdhci_send_command+0x5e9/0x85b [sdhci]
 [<ffffffff81085d46>] ? arch_local_irq_restore+0x6/0xd
 [<ffffffff81085d6f>] ? arch_local_irq_save+0x15/0x1b
 [<ffffffff814b71ac>] ? _raw_spin_unlock_irqrestore+0x17/0x19
 [<ffffffffa00565ba>] sdhci_request+0x11b/0x131 [sdhci]
 [<ffffffffa00df8cf>] mmc_start_request+0x1ac/0x1b3 [mmc_core]
 [<ffffffffa00dffe2>] mmc_start_req+0xe3/0x11e [mmc_core]
 [<ffffffffa029ea80>] mmc_blk_issue_rw_rq+0x85/0x29f [mmc_block]
 [<ffffffff81014b35>] ? paravirt_read_tsc+0x9/0xd
 [<ffffffffa029ef04>] mmc_blk_issue_rq+0x26a/0x28d [mmc_block]
 [<ffffffff8120c76b>] ? blk_start_request+0x3a/0x3f
 [<ffffffffa029fc73>] mmc_queue_thread+0xb7/0x146 [mmc_block]
 [<ffffffffa029fbbc>] ? mmc_blk_probe+0x227/0x227 [mmc_block]
 [<ffffffff81072cdf>] kthread+0x84/0x8c
 [<ffffffff814bfa74>] kernel_thread_helper+0x4/0x10
 [<ffffffff81072c5b>] ? kthread_worker_fn+0x148/0x148
 [<ffffffff814bfa70>] ? gs_change+0x13/0x13

Comment 9 Josh Boyer 2012-06-06 19:33:01 UTC
Is this still happening with 2.6.43/3.3?

Comment 10 gcarter 2012-06-06 19:53:37 UTC
Still happens with Fedora 17, latest kernel 3.4.x and 3.5.x. although not very often.

This is usually what I see as well.

   5.147695] mmcblk0: error -110 sending status command, retrying
[    5.147815] mmcblk0: error -110 sending status command, retrying
[    5.147896] mmcblk0: error -110 sending status command, aborting
[    5.147943] end_request: I/O error, dev mmcblk0, sector 60710784
[    5.147987] Buffer I/O error on device mmcblk0, logical block 7588848
[    5.149220] mmcblk0: error -110 sending status command, retrying
[    5.149296] mmcblk0: error -110 sending status command, retrying
[    5.149374] mmcblk0: error -110 sending status command, aborting
[    5.149426] end_request: I/O error, dev mmcblk0, sector 60710784
[

Of course, this only happens if you leave the SDCARD in the slot on boot.

If you take it out, and insert the SDCARD afterwards, then no problem.

-gc

Comment 11 Josh Boyer 2012-06-06 19:59:51 UTC
If it's happening in 3.5.x kernels, can you please report it directly to the linux-mmc and/or linux-kernel mailing lists?

Comment 12 Fedora End Of Life 2013-04-03 15:37:24 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19

Comment 13 Justin M. Forbes 2013-04-05 19:44:15 UTC
Closing insufficient data as there has been no recent activity on this, please reopen if this is still an issue


Note You need to log in before you can comment on or make changes to this bug.