Bug 738804 - Gedit mistreats mouse clicks when run under twm
Gedit mistreats mouse clicks when run under twm
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-15 16:49 EDT by Göran Uddeborg
Modified: 2013-02-13 16:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 16:44:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2011-09-15 16:49:27 EDT
Description of problem:
I tried to run gedit under a user-script session using twm.  This has worked previously, but in F16 the mouse actions are not interpreted correctly.

Version-Release number of selected component (if applicable):
gedit-3.1.5-1.fc16.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Start a twm session
2. Start up gedit, from a terminal window for example
3. Click on the "open" button in the toolbar
4. Click on "search" in the file selection dialog that comes up
  
Actual results:
The "open" button in the toolbar behaves as if it was clicked.  Nothing happens in the file selection dialog.

Additional info:
Maybe gedit isn't meant to work at all outside a gnome session.  If so, this can be closed.  But since it used to work, I thought I'd report it.  For me it is a regression.

It doesn't matter what one clicks in the file selection dialog.  A file name, a place, the "cancel" button, they all have the same effect: the "open" button in the main window's toolbar looks as if it was clicked.  No other visible effect.

It IS possible to navigate the dialog from the keyboard, using tab and arrow keys.

If I cancel the file dialog, the main gedit window have the same behavior.  If I click anywhere, on a menu name, anything else in the toolbar, the main edit window, they all have the effect that the "open" button looks as if it was clicked.  This is different from before I used the toolbar to bring up the file dialog.  I could open menus with the mouse before that, for example.

The main window too is possible to navigate using the keyboard.  I can exit gedit that way, for example.
Comment 1 Fedora End Of Life 2013-01-16 12:15:18 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora End Of Life 2013-02-13 16:44:12 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.