Bug 738816 - group member/child alertdefs can be deleted
group member/child alertdefs can be deleted
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.1
Unspecified Unspecified
high Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
Mike Foley
:
Depends On:
Blocks: jon30-bugs rhq42
  Show dependency treegraph
 
Reported: 2011-09-15 17:15 EDT by Ian Springer
Modified: 2013-08-05 20:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-18 09:36:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2011-09-15 17:15:58 EDT
We currently allow users to delete group member alertdefs (i.e. child alertdefs of a group alertdef) from the Resource Alerts>Definitions subtab. We may not want to allow this, since then the group alertdef will no longer apply to the entire group.
Comment 1 Charles Crouch 2011-09-22 08:41:29 EDT
Test:
-After deleting member alert, update group alert
Comment 2 Charles Crouch 2011-09-26 17:55:22 EDT
Test:
-After deleting member alert, update group alert and see whether the a new 
member alert gets created
Comment 3 Heiko W. Rupp 2011-09-28 11:52:23 EDT
This may be a valid use case
Comment 4 Heiko W. Rupp 2011-10-18 09:36:01 EDT
THis is the special version of the one of the child definitions has different conditions etc. case.

Users may put filesystems into a comp group and alert on size used. Then remove one disk from this, because it is e.g. so big that it will never fill up

Note You need to log in before you can comment on or make changes to this bug.