Bug 73884 - Anaconda-ks.cfg doesnt completely represent partitioning setup for RAID
Anaconda-ks.cfg doesnt completely represent partitioning setup for RAID
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
: FutureFeature
: 73883 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2002-09-12 17:35 EDT by John Airey
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-08 16:24:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Airey 2002-09-12 17:35:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
The anaconda installer does not create the correct size software RAID partitions

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat Linux 7.3 with software raid partitions
2. Create ks.cfg file from anaconda-ks.cfg file and boot disk
3. Boot system
	

Actual Results:  An error appears that the system cannot install onto disks 
with size "None". The installation fails.

Expected Results:  There should have been no error and the correct RAID 
partitions created and the installation completed.

Additional info:

The problem is caused by the installer writing an incorrect anaconda-ks.cfg. 
Here's an example:

clearpart --linux
#part raid.2 --noformat --onpart hda2
#part raid.5 --noformat --onpart hdc2
#part swap --onpart hda3
#part swap --onpart hdc3
#raid / --fstype ext3 --level=RAID1 raid.2 raid.5

The solution is for software RAID partitions to be represented by start and end 
cylinders, since specifying size may lead to software RAID partitions being 
placed differently on the disk.  For the above example:

#clearpart --linux
#part raid.2 --noformat --start=2 --end=1001 --ondisk=hda
#part raid.5 --noformat --start=2 --end=1001 --ondisk=hdc
#part swap --start=1002 --end=1023 --ondisk=hda
#part swap --start=1002 --end=1023 --ondisk=hdc
#raid / --fstype ext3 --level=RAID1 raid.2 raid.5

This is also a problem with Red Hat 7.2
Comment 1 Michael Fulbright 2002-09-13 14:38:33 EDT
*** Bug 73883 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2005-06-08 16:24:16 EDT
I believe this is fixed in FC4.  Please reopen if you are still seeing this problem.

Note You need to log in before you can comment on or make changes to this bug.